This solution is used within Canada and the U.S.. It combines standards associated with US: NTCIP Warning Device with those for I–F: SNMPv3/TLS. The US: NTCIP Warning Device standards include a composite of upper–layer standards that support monitoring for unsafe traffic activities and displaying warning to drivers. The I–F: SNMPv3/TLS standards include lower–layer standards that support secure center–to–field and field–to–field communications using simple network management protocol (SNMPv3); implementations are strongly encouraged to use the TLS for SNMP security option for this solution to ensure adequate security.
| Level | DocNum | FullName | Description |
|---|
| Mgmt | NTCIP 1201 | NTCIP Global Object (GO) Definitions | This standard defines SNMP objects (data elements) used by a wide range of field devices like time and versioning information. |
|---|
| Mgmt | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Mgmt | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Mgmt | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Mgmt | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Mgmt | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Mgmt | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| Mgmt | IETF RFC 3418 | Management Information Base (MIB) for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the MIB to configure and manage an SNMP entity. |
|---|
| Mgmt | IETF RFC 4293 | Management Information Base for the Internet Protocol (IP) | This standard (RFC) defines the MIB that manages an IP entity. |
|---|
| Security | IETF RFC 6353 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines how to use the TLS authentication service to provide authentication within the access control mechanism of SNMP. |
|---|
| Security | IETF RFC 9456 | Updates to the TLS Transport Model for SNMP | |
|---|
| ITS Application Entity | NTCIP 1209 | NTCIP Object Definitions for Transportation Sensor Systems (TSS) | This standard defines SNMP objects (data elements) to monitor and control transportation system sensors that measure real–time vehicular traffic information. |
|---|
| ITS Application Entity | NTCIP 1205 | NTCIP Objects for CCTV Camera Control | This standard defines SNMP objects (data elements) for control and monitoring of closed–circuit television (CCTV) camera controllers. |
|---|
| ITS Application Entity | NTCIP 1203 | NTCIP Object Definitions for Dynamic Message Signs (DMS) | This standard defines SNMP objects (data elements) for monitoring and controlling dynamic message signs (such as variable message signs). |
|---|
| Facilities | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Facilities | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Facilities | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Facilities | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Facilities | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Facilities | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| Facilities | NTCIP 1209 | NTCIP Object Definitions for Transportation Sensor Systems (TSS) | This standard defines SNMP objects (data elements) to monitor and control transportation system sensors that measure real–time vehicular traffic information. |
|---|
| Facilities | NTCIP 1205 | NTCIP Objects for CCTV Camera Control | This standard defines SNMP objects (data elements) for control and monitoring of closed–circuit television (CCTV) camera controllers. |
|---|
| Facilities | NTCIP 1203 | NTCIP Object Definitions for Dynamic Message Signs (DMS) | This standard defines SNMP objects (data elements) for monitoring and controlling dynamic message signs (such as variable message signs). |
|---|
| TransNet | IETF RFC 4291 | IP Version 6 Addressing Architecture | This standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses. |
|---|
| TransNet | IETF RFC 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification | This standard (RFC) defines the control messages to manage IPv6. |
|---|
| TransNet | IETF RFC 8200 | Internet Protocol, Version 6 | This document specifies version 6 of the Internet Protocol (IPv6). |
|---|
| TransNet | IETF RFC 9293 | Transmission Control Protocol | This document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168. |
|---|
| Access | NTCIP 2104 | NTCIP SP–Ethernet | This standard defines the Access Layer for center–to–field communications where the local connection is some variant of Ethernet. |
|---|
One significant or possibly a couple minor issues. For existing deployments, the chosen solution likely has identified security or management issues not addressed by the communications solution. Deployers should consider additional security measures, such as communications link and physical security as part of these solutions. They should also review the management issues to see if they are relevant to their deployment and would require mitigation. For new deployments, the deployment efforts should consider a path to addressing these issues as a part of their design activities. The solution does not by itself provide a fully secure implementation without additional work.
| Issue | Severity | Description | Associated Standard | Associated Triple |
|---|
| Use case not considered in design (critical) | High | While the indicated standards nominally address the information flow, the design details may not meet performance or other requirements because this particular use case was not the focus of the design effort. | (None) | Kane County Field Equipment=>lane management information=>Kane County TMC |
|---|
| Use case not considered in design (critical) | High | While the indicated standards nominally address the information flow, the design details may not meet performance or other requirements because this particular use case was not the focus of the design effort. | (None) | Kane County Field Equipment=>work zone warning status=>Kane County Maintenance Operations |
|---|
| Use case not considered in design (critical) | High | While the indicated standards nominally address the information flow, the design details may not meet performance or other requirements because this particular use case was not the focus of the design effort. | (None) | IDOT District 1 Traffic Systems Center Field Equipment=>lane management information=>IDOT District 1 Traffic Systems Center (TSC) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Kendall County Field Equipment=>speed monitoring information=>Kendall County TMC |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | OHare Airport Operations Center=>speed monitoring control=>City of Chicago Department of Aviation Field Equipment |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Kane County Maintenance Operations=>speed monitoring control=>Kane County Field Equipment |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Kane County Maintenance Operations=>work zone warning device control=>Kane County Field Equipment |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Kane County Field Equipment=>speed monitoring information=>Kane County Maintenance Operations |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Kane County Field Equipment=>work zone warning status=>Kane County Maintenance Operations |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Kane County Field Equipment=>speed monitoring information=>Kane County TMC |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | City of Chicago Department of Aviation Field Equipment=>speed monitoring information=>OHare Airport Operations Center |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Kendall County TMC=>speed monitoring control=>Kendall County Field Equipment |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Automated Enforcement Cameras=>speed monitoring information=>City of Chicago DOT Arterial Performance Monitoring System |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | City of Chicago DOT Arterial Performance Monitoring System=>speed monitoring control=>Automated Enforcement Cameras |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Kane County TMC=>speed monitoring control=>Kane County Field Equipment |
|---|
| Out of date (medium) | Medium | The standard includes normative references to other standards that have been subject to significant changes that can impact interoperability or security of systems and the industry has not specified if and how these updates should be implemented for deployments of this standard. | IETF RFC 6353 TLS for SNMP | (All) |
|---|
| Update data to SNMPv3 | Low | Data has been defined for SNMPv1, but needs to be updated to SNMPv3 format. | (None) | (All) |
|---|
| Use TLS for SNMP Option | Low | The standard allows for multiple security mechanisms. The only defined mechanism that meets the requirements for C–ITS is the one based on TLS. | (None) | (All) |
|---|
| Source | Destination | Flow |
|---|
| Automated Enforcement Cameras | City of Chicago DOT Arterial Performance Monitoring System | speed monitoring information |
|---|
| Automated Enforcement Cameras | Violation Enforcement Processing Center | speed monitoring information |
|---|
| City of Chicago Department of Aviation Field Equipment | OHare Airport Operations Center | speed monitoring information |
|---|
| City of Chicago DOT Arterial Performance Monitoring System | Automated Enforcement Cameras | speed monitoring control |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | IDOT District 1 Traffic Systems Center (TSC) | lane management information |
|---|
| Kane County Field Equipment | Kane County Maintenance Operations | speed monitoring information |
|---|
| Kane County Field Equipment | Kane County Maintenance Operations | work zone warning status |
|---|
| Kane County Field Equipment | Kane County TMC | lane management information |
|---|
| Kane County Field Equipment | Kane County TMC | speed monitoring information |
|---|
| Kane County Maintenance Operations | Kane County Field Equipment | speed monitoring control |
|---|
| Kane County Maintenance Operations | Kane County Field Equipment | work zone warning device control |
|---|
| Kane County TMC | Kane County Field Equipment | speed monitoring control |
|---|
| Kendall County Field Equipment | Kendall County TMC | speed monitoring information |
|---|
| Kendall County TMC | Kendall County Field Equipment | speed monitoring control |
|---|
| OHare Airport Operations Center | City of Chicago Department of Aviation Field Equipment | speed monitoring control |
|---|
| Violation Enforcement Processing Center | Automated Enforcement Cameras | speed monitoring control |
|---|