US: NTCIP Signal System Masters - SNMPv3/TLS

Description

This solution is used within Canada and the U.S.. It combines standards associated with US: NTCIP Signal System Masters with those for I–F: SNMPv3/TLS. The US: NTCIP Signal System Masters standards include upper–layer standards required to implement center–to–field signal–system master communications. The I–F: SNMPv3/TLS standards include lower–layer standards that support secure center–to–field and field–to–field communications using simple network management protocol (SNMPv3); implementations are strongly encouraged to use the TLS for SNMP security option for this solution to ensure adequate security.

Includes Standards

LevelDocNumFullNameDescription
MgmtNTCIP 1201NTCIP Global Object (GO) DefinitionsThis standard defines SNMP objects (data elements) used by a wide range of field devices like time and versioning information.
MgmtIETF RFC 3411An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksThis standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture.
MgmtIETF RFC 3412Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity.
MgmtIETF RFC 3413Simple Network Management Protocol (SNMP) ApplicationsThis standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys.
MgmtIETF RFC 3414User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model.
MgmtIETF RFC 3415View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP.
MgmtIETF RFC 3416Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the message structure and protocol operations used by SNMPv3.
MgmtIETF RFC 3418Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the MIB to configure and manage an SNMP entity.
MgmtIETF RFC 4293Management Information Base for the Internet Protocol (IP)This standard (RFC) defines the MIB that manages an IP entity.
SecurityIETF RFC 6353Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)This standard (RFC) defines how to use the TLS authentication service to provide authentication within the access control mechanism of SNMP.
SecurityIETF RFC 9456Updates to the TLS Transport Model for SNMP 
ITS Application EntityNTCIP 1202NTCIP Object Definitions for ASCThis standard defines SNMP objects (data elements) for a center to control a traffic signal and its interface with connected vehicles.
ITS Application EntityNTCIP 1210NTCIP Objects for Signal System MastersThis standard defines SNMP objects (data elements) for monitoring and controlling signal system master controllers.
FacilitiesNTCIP 1202NTCIP Object Definitions for ASCThis standard defines SNMP objects (data elements) for a center to control a traffic signal and its interface with connected vehicles.
FacilitiesNTCIP 1210NTCIP Objects for Signal System MastersThis standard defines SNMP objects (data elements) for monitoring and controlling signal system master controllers.
FacilitiesIETF RFC 3411An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksThis standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture.
FacilitiesIETF RFC 3412Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity.
FacilitiesIETF RFC 3413Simple Network Management Protocol (SNMP) ApplicationsThis standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys.
FacilitiesIETF RFC 3414User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model.
FacilitiesIETF RFC 3415View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP.
FacilitiesIETF RFC 3416Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the message structure and protocol operations used by SNMPv3.
TransNetIETF RFC 4291IP Version 6 Addressing ArchitectureThis standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses.
TransNetIETF RFC 4443Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationThis standard (RFC) defines the control messages to manage IPv6.
TransNetIETF RFC 8200Internet Protocol, Version 6This document specifies version 6 of the Internet Protocol (IPv6).
TransNetIETF RFC 9293Transmission Control ProtocolThis document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168.
AccessNTCIP 2104NTCIP SP–EthernetThis standard defines the Access Layer for center–to–field communications where the local connection is some variant of Ethernet.

Readiness: High–Moderate

Readiness Description

One significant or possibly a couple minor issues. For existing deployments, the chosen solution likely has identified security or management issues not addressed by the communications solution. Deployers should consider additional security measures, such as communications link and physical security as part of these solutions. They should also review the management issues to see if they are relevant to their deployment and would require mitigation. For new deployments, the deployment efforts should consider a path to addressing these issues as a part of their design activities. The solution does not by itself provide a fully secure implementation without additional work.

Issues

IssueSeverityDescriptionAssociated StandardAssociated Triple
Out of date (medium)MediumThe standard includes normative references to other standards that have been subject to significant changes that can impact interoperability or security of systems and the industry has not specified if and how these updates should be implemented for deployments of this standard.IETF RFC 6353 TLS for SNMP(All)
Update data to SNMPv3LowData has been defined for SNMPv1, but needs to be updated to SNMPv3 format.(None)(All)
Use TLS for SNMP OptionLowThe standard allows for multiple security mechanisms. The only defined mechanism that meets the requirements for C–ITS is the one based on TLS.(None)(All)

Supports Interfaces

SourceDestinationFlow
Automated Enforcement CamerasCity of Chicago OEMC Field Equipmentsignal control coordination
Automated Enforcement CamerasDuPage County Field Equipmentsignal control coordination
Automated Enforcement CamerasIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
Automated Enforcement CamerasIDOT District 1 ComCenter Field Equipmentsignal control coordination
Automated Enforcement CamerasIDOT District 1 Traffic Systems Center Field Equipmentsignal control coordination
Automated Enforcement CamerasKane County Field Equipmentsignal control coordination
City of Chicago – Skyway Concession Company LLC Field EquipmentCity of Chicago OEMC Field Equipmentsignal control coordination
City of Chicago Department of Aviation Field EquipmentCity of Chicago OEMC Field Equipmentsignal control coordination
City of Chicago Department of Aviation Field EquipmentOHare Airport Operations Centersignal fault data
City of Chicago DSS Field EquipmentCity of Chicago OEMC Field Equipmentsignal control coordination
City of Chicago DSS Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentsignal control coordination
City of Chicago OEMC Field EquipmentAutomated Enforcement Camerassignal control coordination
City of Chicago OEMC Field EquipmentCity of Chicago – Skyway Concession Company LLC Field Equipmentsignal control coordination
City of Chicago OEMC Field EquipmentCity of Chicago Department of Aviation Field Equipmentsignal control coordination
City of Chicago OEMC Field EquipmentCity of Chicago DSS Field Equipmentsignal control coordination
City of Chicago OEMC Field EquipmentCity of Chicago TMCsignal fault data
City of Chicago OEMC Field EquipmentCook County Department of Transportation and Highways Field Equipmentsignal control coordination
City of Chicago OEMC Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
City of Chicago OEMC Field EquipmentIDOT District 1 ComCenter Field Equipmentsignal control coordination
City of Chicago OEMC Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentsignal control coordination
City of Chicago TMCCity of Chicago OEMC Field Equipmentsignal control commands
City of Chicago TMCCity of Chicago OEMC Field Equipmentsignal control device configuration
City of Chicago TMCCity of Chicago OEMC Field Equipmentsignal control plans
City of Chicago TMCCity of Chicago OEMC Field Equipmentsignal system configuration
Cook County Department of Transportation and Highways Field EquipmentCity of Chicago OEMC Field Equipmentsignal control coordination
Cook County Department of Transportation and Highways Field EquipmentCook County TMCsignal fault data
Cook County Department of Transportation and Highways Field EquipmentDuPage County Field Equipmentsignal control coordination
Cook County Department of Transportation and Highways Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
Cook County Department of Transportation and Highways Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentsignal control coordination
Cook County Department of Transportation and Highways Field EquipmentIllinois Tollway TMC Field Equipmentsignal control coordination
Cook County Department of Transportation and Highways Field EquipmentLake County Field Equipmentsignal control coordination
Cook County TMCCook County Department of Transportation and Highways Field Equipmentsignal control commands
Cook County TMCCook County Department of Transportation and Highways Field Equipmentsignal control device configuration
Cook County TMCCook County Department of Transportation and Highways Field Equipmentsignal control plans
Cook County TMCCook County Department of Transportation and Highways Field Equipmentsignal system configuration
DuPage County Centralized Signal Management SystemDuPage County Field Equipmentsignal control commands
DuPage County Centralized Signal Management SystemDuPage County Field Equipmentsignal control device configuration
DuPage County Centralized Signal Management SystemDuPage County Field Equipmentsignal control plans
DuPage County Centralized Signal Management SystemDuPage County Field Equipmentsignal system configuration
DuPage County Field EquipmentAutomated Enforcement Camerassignal control coordination
DuPage County Field EquipmentCook County Department of Transportation and Highways Field Equipmentsignal control coordination
DuPage County Field EquipmentDuPage County Centralized Signal Management Systemsignal fault data
DuPage County Field EquipmentDuPage County TMCsignal fault data
DuPage County Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
DuPage County Field EquipmentIllinois Tollway TMC Field Equipmentsignal control coordination
DuPage County Field EquipmentKane County Field Equipmentsignal control coordination
DuPage County Field EquipmentMunicipal/Township Field Equipmentsignal control coordination
DuPage County Field EquipmentWill County Field Equipmentsignal control coordination
DuPage County TMCDuPage County Field Equipmentsignal control commands
DuPage County TMCDuPage County Field Equipmentsignal control device configuration
DuPage County TMCDuPage County Field Equipmentsignal control plans
DuPage County TMCDuPage County Field Equipmentsignal system configuration
Grundy County Field EquipmentGrundy County TMCsignal fault data
Grundy County TMCGrundy County Field Equipmentsignal control commands
Grundy County TMCGrundy County Field Equipmentsignal control device configuration
Grundy County TMCGrundy County Field Equipmentsignal control plans
Grundy County TMCGrundy County Field Equipmentsignal system configuration
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentAutomated Enforcement Camerassignal control coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentCity of Chicago OEMC Field Equipmentsignal control coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentDuPage County Field Equipmentsignal control coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Signal Operationssignal fault data
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentIDOT District 1 ComCenter Field Equipmentsignal control coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentsignal control coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentIllinois Tollway TMC Field Equipmentsignal control coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentLake County Field Equipmentsignal control coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentMunicipal/Township Field Equipmentsignal control coordination
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control commands
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control device configuration
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control plans
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal system configuration
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 ComCenter Field Equipmentsignal control commands
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 ComCenter Field Equipmentsignal control device configuration
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 ComCenter Field Equipmentsignal control plans
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 ComCenter Field Equipmentsignal system configuration
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 Traffic Systems Center Field Equipmentsignal control commands
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 Traffic Systems Center Field Equipmentsignal control device configuration
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 Traffic Systems Center Field Equipmentsignal control plans
IDOT District 1 Bureau of Traffic – Arterial Signal OperationsIDOT District 1 Traffic Systems Center Field Equipmentsignal system configuration
IDOT District 1 ComCenterIDOT District 1 ComCenter Field Equipmentsignal control commands
IDOT District 1 ComCenterIDOT District 1 ComCenter Field Equipmentsignal control device configuration
IDOT District 1 ComCenterIDOT District 1 ComCenter Field Equipmentsignal control plans
IDOT District 1 ComCenterIDOT District 1 ComCenter Field Equipmentsignal system configuration
IDOT District 1 ComCenterIDOT District 1 Traffic Systems Center Field Equipmentsignal control commands
IDOT District 1 ComCenterIDOT District 1 Traffic Systems Center Field Equipmentsignal control device configuration
IDOT District 1 ComCenterIDOT District 1 Traffic Systems Center Field Equipmentsignal control plans
IDOT District 1 ComCenterIDOT District 1 Traffic Systems Center Field Equipmentsignal system configuration
IDOT District 1 ComCenter Field EquipmentAutomated Enforcement Camerassignal control coordination
IDOT District 1 ComCenter Field EquipmentCity of Chicago OEMC Field Equipmentsignal control coordination
IDOT District 1 ComCenter Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
IDOT District 1 ComCenter Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Signal Operationssignal fault data
IDOT District 1 ComCenter Field EquipmentIDOT District 1 ComCentersignal fault data
IDOT District 1 ComCenter Field EquipmentIDOT District 1 Traffic Systems Center (TSC)signal fault data
IDOT District 1 ComCenter Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentsignal control coordination
IDOT District 1 ComCenter Field EquipmentIllinois Tollway TMC Field Equipmentsignal control coordination
IDOT District 1 ComCenter Field EquipmentLake County Field Equipmentsignal control coordination
IDOT District 1 Traffic Systems Center (TSC)IDOT District 1 ComCenter Field Equipmentsignal control commands
IDOT District 1 Traffic Systems Center (TSC)IDOT District 1 ComCenter Field Equipmentsignal control device configuration
IDOT District 1 Traffic Systems Center (TSC)IDOT District 1 ComCenter Field Equipmentsignal control plans
IDOT District 1 Traffic Systems Center (TSC)IDOT District 1 ComCenter Field Equipmentsignal system configuration
IDOT District 1 Traffic Systems Center Field EquipmentAutomated Enforcement Camerassignal control coordination
IDOT District 1 Traffic Systems Center Field EquipmentCity of Chicago DSS Field Equipmentsignal control coordination
IDOT District 1 Traffic Systems Center Field EquipmentCity of Chicago OEMC Field Equipmentsignal control coordination
IDOT District 1 Traffic Systems Center Field EquipmentCook County Department of Transportation and Highways Field Equipmentsignal control coordination
IDOT District 1 Traffic Systems Center Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
IDOT District 1 Traffic Systems Center Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Signal Operationssignal fault data
IDOT District 1 Traffic Systems Center Field EquipmentIDOT District 1 ComCentersignal fault data
IDOT District 1 Traffic Systems Center Field EquipmentIDOT District 1 ComCenter Field Equipmentsignal control coordination
IDOT District 1 Traffic Systems Center Field EquipmentIDOT Toll Plazas / Gantriessignal control coordination
IDOT District 1 Traffic Systems Center Field EquipmentIllinois Tollway TMC Field Equipmentsignal control coordination
IDOT Toll Plazas / GantriesIDOT District 1 Traffic Systems Center Field Equipmentsignal control coordination
Illinois Tollway TMC Field EquipmentCook County Department of Transportation and Highways Field Equipmentsignal control coordination
Illinois Tollway TMC Field EquipmentDuPage County Field Equipmentsignal control coordination
Illinois Tollway TMC Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
Illinois Tollway TMC Field EquipmentIDOT District 1 ComCenter Field Equipmentsignal control coordination
Illinois Tollway TMC Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentsignal control coordination
Illinois Tollway TMC Field EquipmentKane County Field Equipmentsignal control coordination
Illinois Tollway TMC Field EquipmentLake County Field Equipmentsignal control coordination
Kane County Field EquipmentAutomated Enforcement Camerassignal control coordination
Kane County Field EquipmentDuPage County Field Equipmentsignal control coordination
Kane County Field EquipmentIllinois Tollway TMC Field Equipmentsignal control coordination
Kane County Field EquipmentKane County TMCsignal fault data
Kane County TMCKane County Field Equipmentsignal control commands
Kane County TMCKane County Field Equipmentsignal control device configuration
Kane County TMCKane County Field Equipmentsignal control plans
Kane County TMCKane County Field Equipmentsignal system configuration
Kendall County Field EquipmentKendall County TMCsignal fault data
Kendall County TMCKendall County Field Equipmentsignal control commands
Kendall County TMCKendall County Field Equipmentsignal control device configuration
Kendall County TMCKendall County Field Equipmentsignal control plans
Kendall County TMCKendall County Field Equipmentsignal system configuration
Lake County Field EquipmentCook County Department of Transportation and Highways Field Equipmentsignal control coordination
Lake County Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
Lake County Field EquipmentIDOT District 1 ComCenter Field Equipmentsignal control coordination
Lake County Field EquipmentIllinois Tollway TMC Field Equipmentsignal control coordination
Lake County Field EquipmentLake County PASSAGE TMCsignal fault data
Lake County PASSAGE TMCLake County Field Equipmentsignal control commands
Lake County PASSAGE TMCLake County Field Equipmentsignal control device configuration
Lake County PASSAGE TMCLake County Field Equipmentsignal control plans
Lake County PASSAGE TMCLake County Field Equipmentsignal system configuration
McHenry County Field EquipmentMcHenry County TMCsignal fault data
McHenry County TMCMcHenry County Field Equipmentsignal control commands
McHenry County TMCMcHenry County Field Equipmentsignal control device configuration
McHenry County TMCMcHenry County Field Equipmentsignal control plans
McHenry County TMCMcHenry County Field Equipmentsignal system configuration
Municipal TMCsMunicipal/Township Field Equipmentsignal control commands
Municipal TMCsMunicipal/Township Field Equipmentsignal control device configuration
Municipal TMCsMunicipal/Township Field Equipmentsignal control plans
Municipal TMCsMunicipal/Township Field Equipmentsignal system configuration
Municipal/Township Field EquipmentDuPage County Field Equipmentsignal control coordination
Municipal/Township Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentsignal control coordination
Municipal/Township Field EquipmentMunicipal TMCssignal fault data
OHare Airport Operations CenterCity of Chicago Department of Aviation Field Equipmentsignal control commands
OHare Airport Operations CenterCity of Chicago Department of Aviation Field Equipmentsignal control device configuration
OHare Airport Operations CenterCity of Chicago Department of Aviation Field Equipmentsignal control plans
OHare Airport Operations CenterCity of Chicago Department of Aviation Field Equipmentsignal system configuration
Will County Field EquipmentDuPage County Field Equipmentsignal control coordination
Will County Field EquipmentWill County TMCsignal fault data
Will County TMCWill County Field Equipmentsignal control commands
Will County TMCWill County Field Equipmentsignal control device configuration
Will County TMCWill County Field Equipmentsignal control plans
Will County TMCWill County Field Equipmentsignal system configuration