US: GTFS - Secure Internet (ITS)

Description

This solution is used within Canada and the U.S.. It combines standards associated with US: GTFS with those for I–I: Secure Internet (ITS). The US: GTFS standards include upper–layer standards required to implement public, transit–related communications. The I–I: Secure Internet (ITS) standards include lower–layer standards that support secure communications between ITS equipment using X.509 or IEEE 1609.2 security certificates.

Includes Standards

LevelDocNumFullNameDescription
MgmtIETF RFC 3411An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksThis standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture.
MgmtIETF RFC 3412Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity.
MgmtIETF RFC 3413Simple Network Management Protocol (SNMP) ApplicationsThis standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys.
MgmtIETF RFC 3414User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model.
MgmtIETF RFC 3415View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP.
MgmtIETF RFC 3416Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the message structure and protocol operations used by SNMPv3.
MgmtIETF RFC 3418Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the MIB to configure and manage an SNMP entity.
MgmtIETF RFC 4293Management Information Base for the Internet Protocol (IP)This standard (RFC) defines the MIB that manages an IP entity.
SecurityIETF RFC 5280Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileThis standard (RFC) defines how to use X.509 certificates for secure communications over the Internet.
SecurityIETF RFC 8446The Transport Layer Security (TLS) ProtocolThis standard (RFC) specifies Version 1.3 of the Transport Layer Security (TLS) protocol. The TLS protocol provides communications security over the Internet. The protocol allows client/server applications to communicate in a way that is designed to prevent eavesdropping, tampering, or message forgery.
ITS Application EntityGTFS RealtimeGeneral Transit Feed Specification RealtimeThis document defines a feed specification that allows public transportation agencies to provide real–time updates about their fleet to application developers. It is an extension to GTFS (General Transit Feed Specification), an open data format for public transportation schedules and associated geographic information. GTFS Realtime was designed around ease of implementation, good GTFS interoperability and a focus on passenger information.
ITS Application EntityGTFSGeneral Transit Feed SpecificationThis document defines a common (open data) format for exchanging public transportation schedules and associated geographic information.
FacilitiesIETF RFC 9110HTTP SemanticsThe Hypertext Transfer Protocol (HTTP) is a stateless application–level protocol for distributed, collaborative, hypertext information systems. This document describes the overall architecture of HTTP, establishes common terminology, and defines aspects of the protocol that are shared by all versions. In this definition are core protocol elements, extensibility mechanisms, and the "http" and "https" Uniform Resource Identifier (URI) schemes.
FacilitiesIETF RFC 9112HTTP/1.1The Hypertext Transfer Protocol (HTTP) is a stateless application–level protocol for distributed, collaborative, hypertext information systems. This document specifies the HTTP/1.1 message syntax, message parsing, connection management, and related security concerns.
FacilitiesISO 21320–1Information technology — Document Container File — Part 1: CoreISO/IEC 21320–1 specifies the core requirements for 1) document container files, and 2) implementations that produce and/or consume document container files. It normatively references the Zip File Format Specification version 6.3.3 of PKWARE(R) Inc. Document container files are conforming Zip files as specified by that document.
FacilitiesIETF RFC 4180Common Format and MIME Type for Comma–Separated Values (CSV) FilesThis standard (RFC) documents the format used for Comma–Separated Values (CSV) files and registers the associated MIME type "text/csv".
FacilitiesIETF RFC 7159The JavaScript Object Notation (JSON) Data Interchange FormatThe JavaScript Object Notation (JSON), a lightweight, text–based, language–independent data interchange format. It was derived from the ECMAScript Programming Language Standard. JSON defines a small set of formatting rules for the portable representation of structured data. This document removes inconsistencies with other specifications of JSON, repairs specification errors, and offers experience–based interoperability guidance.
TransNetIETF RFC 4291IP Version 6 Addressing ArchitectureThis standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses.
TransNetIETF RFC 4443Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationThis standard (RFC) defines the control messages to manage IPv6.
TransNetIETF RFC 8200Internet Protocol, Version 6This document specifies version 6 of the Internet Protocol (IPv6).
TransNetIETF RFC 9293Transmission Control ProtocolThis document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168.
Access Internet Subnet AlternativesA set of alternative standards that includes any Subnet Layer method of connecting to the Internet.

Readiness: Moderate–Low

Readiness Description

Multiple significant and minor issues.  For existing deployments, the chosen solution is likely deficient in security or management capabilities, and the issues should be reviewed and upgrades developed as needed. Some solutions in this category may also be becoming obsolete from an interoperability perspective and if this is the case, then upgrades should be planned as soon as possible. For new deployments, the solution may be viable for pilots when applied to the triples it supports; such pilot deployments should consider a path to addressing these issues as a part of their design activities. The solution does not provide sufficient interoperability, management, and security to enable proper, full–scale deployment without  additional work.

Issues

IssueSeverityDescriptionAssociated StandardAssociated Triple
Application specification not definedHighThe logic, performance, and application security rules are not defined for this information flow.(None)(All)
Not a standard (minor)LowThe document is publicly available and widely used but it is not currently a formal standard.GTFS Realtime(All)
Not a standard (minor)LowThe document is publicly available and widely used but it is not currently a formal standard.General Transit Feed Specification(All)

Supports Interfaces

SourceDestinationFlow
Chicago Transit Authority ATSS SystemChicago Transit Authority Active Transit Station Signstransit traveler information
Chicago Transit Authority ATSS SystemChicago Transit Authority BusInfo Signstransit traveler information
Chicago Transit Authority Bus Info SystemChicago Transit Authority BusInfo Signstransit traveler information
Chicago Transit Authority Bus Info SystemChicago Transit Authority Control Centertransit service coordination
Chicago Transit Authority Bus Info SystemRegional Transportation Authority Travel Information Center (TIC)transit service coordination
Chicago Transit Authority Bus Info SystemRTA/NITA Transit Hubtransit service coordination
Chicago Transit Authority Cash Revenue Collection CenterChicago Transit Authority Cash Fare Collection Equipmenttransit traveler information
Chicago Transit Authority Control CenterChicago Transit Authority ATSS Systemtransit service coordination
Chicago Transit Authority Control CenterChicago Transit Authority Bus Info Systemtransit service coordination
Chicago Transit Authority Control CenterCity of Chicago TMCtransit system data
Chicago Transit Authority Control CenterIDOT District 1 Traffic Systems Center (TSC)transit system data
Chicago Transit Authority Control CenterIndependent School District Dispatchtransit service coordination
Chicago Transit Authority Control CenterMidway Airport Operations Centertransit system data
Chicago Transit Authority Control CenterOHare Airport Operations Centertransit system data
Chicago Transit Authority Control CenterPace Control Center (IBS)transit service coordination
Chicago Transit Authority Control CenterRegional Transportation Authority Travel Information Center (TIC)transit service coordination
Chicago Transit Authority Control CenterRTA InfoTrans Signstransit traveler information
Chicago Transit Authority Control CenterRTA/NITA Transit Hubtransit service coordination
Independent School District DispatchChicago Transit Authority Control Centertransit service coordination
Independent School District DispatchMunicipal Transit Operationstransit service coordination
Independent School District DispatchPace Control Center (IBS)transit service coordination
Independent School District DispatchPrivate Taxi Dispatchtransit service coordination
Kenosha Transit DispatchMetra Consolidated Control Facilitytransit service coordination
Metra Consolidated Control FacilityCity of Chicago TMCtransit system data
Metra Consolidated Control FacilityCook County TMCtransit system data
Metra Consolidated Control FacilityDuPage County TMCtransit system data
Metra Consolidated Control FacilityIDOT District 1 Bureau of Traffic – Arterial Signal Operationstransit system data
Metra Consolidated Control FacilityIDOT District 1 Traffic Systems Center (TSC)transit system data
Metra Consolidated Control FacilityKane County TMCtransit system data
Metra Consolidated Control FacilityKendall County TMCtransit system data
Metra Consolidated Control FacilityKenosha Transit Dispatchtransit service coordination
Metra Consolidated Control FacilityLake County PASSAGE TMCtransit system data
Metra Consolidated Control FacilityMcHenry County TMCtransit system data
Metra Consolidated Control FacilityMetra GPS Center (TIMS)transit service coordination
Metra Consolidated Control FacilityMetra Public Address Systemtransit traveler information
Metra Consolidated Control FacilityMunicipal Transit Operationstransit service coordination
Metra Consolidated Control FacilityNICTD Dispatchtransit service coordination
Metra Consolidated Control FacilityPace Control Center (IBS)transit service coordination
Metra Consolidated Control FacilityPrivate Taxi Dispatchtransit service coordination
Metra Consolidated Control FacilityRegional Transportation Authority Travel Information Center (TIC)transit service coordination
Metra Consolidated Control FacilityRTA/NITA Transit Hubtransit service coordination
Metra Consolidated Control FacilityWill County TMCtransit system data
Metra GPS Center (TIMS)Metra Consolidated Control Facilitytransit service coordination
Metra GPS Center (TIMS)Metra Passenger Information Display Systemtransit service coordination
Metra GPS Center (TIMS)Metra Public Address Systemtransit traveler information
Metra GPS Center (TIMS)Metra Visual Information Display System (VIDS)transit traveler information
Metra GPS Center (TIMS)Regional Transportation Authority Travel Information Center (TIC)transit service coordination
Metra GPS Center (TIMS)RTA/NITA Transit Hubtransit service coordination
Metra Passenger Information Display SystemMetra GPS Center (TIMS)transit service coordination
Metra Passenger Information Display SystemMetra Public Address Systemtransit traveler information
Metra Passenger Information Display SystemMetra Visual Information Display System (VIDS)transit traveler information
Metra Passenger Information Display SystemRegional Transportation Authority Travel Information Center (TIC)transit service coordination
Municipal Transit OperationsIndependent School District Dispatchtransit service coordination
Municipal Transit OperationsMetra Consolidated Control Facilitytransit service coordination
Municipal Transit OperationsPrivate Bus Dispatchtransit service coordination
Municipal Transit OperationsRTA/NITA Transit Hubtransit service coordination
NICTD DispatchMetra Consolidated Control Facilitytransit service coordination
NICTD DispatchPace Control Center (IBS)transit service coordination
Other Regional Paratransit DispatchPace Control Center (IBS)transit service coordination
Other Regional Paratransit DispatchPace Regional Paratransit Dispatchtransit service coordination
Pace BusInfo SystemPace BusInfo Signstransit traveler information
Pace BusInfo SystemPace Control Center (IBS)transit service coordination
Pace BusInfo SystemRTA/NITA Transit Hubtransit service coordination
Pace Control Center (IBS)Chicago Transit Authority Control Centertransit service coordination
Pace Control Center (IBS)City of Chicago TMCtransit system data
Pace Control Center (IBS)Cook County TMCtransit system data
Pace Control Center (IBS)DuPage County TMCtransit system data
Pace Control Center (IBS)Independent School District Dispatchtransit service coordination
Pace Control Center (IBS)Kane County TMCtransit system data
Pace Control Center (IBS)Lake County PASSAGE TMCtransit system data
Pace Control Center (IBS)McHenry County TMCtransit system data
Pace Control Center (IBS)Metra Consolidated Control Facilitytransit service coordination
Pace Control Center (IBS)NICTD Dispatchtransit service coordination
Pace Control Center (IBS)Other Regional Paratransit Dispatchtransit service coordination
Pace Control Center (IBS)Pace BusInfo Systemtransit service coordination
Pace Control Center (IBS)Pace Regional Paratransit Dispatchtransit service coordination
Pace Control Center (IBS)Private Bus Dispatchtransit service coordination
Pace Control Center (IBS)Private Taxi Dispatchtransit service coordination
Pace Control Center (IBS)Regional Transportation Authority Travel Information Center (TIC)transit service coordination
Pace Control Center (IBS)RTA/NITA Transit Hubtransit service coordination
Pace Control Center (IBS)Will County TMCtransit system data
Pace Regional Paratransit DispatchGrundy County TMCtransit system data
Pace Regional Paratransit DispatchKendall County TMCtransit system data
Pace Regional Paratransit DispatchOther Regional Paratransit Dispatchtransit service coordination
Pace Regional Paratransit DispatchPace Control Center (IBS)transit service coordination
Pace Regional Paratransit DispatchPrivate Bus Dispatchtransit service coordination
Pace Regional Paratransit DispatchPrivate Taxi Dispatchtransit service coordination
Pace Regional Paratransit DispatchPublic/Non–Profit Paratransit Servicestransit service coordination
Pace Regional Paratransit DispatchRTA/NITA Transit Hubtransit service coordination
Private Bus DispatchMunicipal Transit Operationstransit service coordination
Private Bus DispatchPace Control Center (IBS)transit service coordination
Private Bus DispatchPace Regional Paratransit Dispatchtransit service coordination
Private Bus DispatchPublic/Non–Profit Paratransit Servicestransit service coordination
Private Bus DispatchRegional Transportation Authority Travel Information Center (TIC)transit service coordination
Private Bus DispatchRTA/NITA Transit Hubtransit service coordination
Private Taxi DispatchIndependent School District Dispatchtransit service coordination
Private Taxi DispatchMetra Consolidated Control Facilitytransit service coordination
Private Taxi DispatchPace Regional Paratransit Dispatchtransit service coordination
Private Taxi DispatchRTA/NITA Transit Hubtransit service coordination
Public/Non–Profit Paratransit ServicesPace Regional Paratransit Dispatchtransit service coordination
Public/Non–Profit Paratransit ServicesRegional Transportation Authority Travel Information Center (TIC)transit service coordination
Public/Non–Profit Paratransit ServicesRTA/NITA Transit Hubtransit service coordination
Regional Transportation Authority Travel Information Center (TIC)Chicago Transit Authority Control Centertransit service coordination
Regional Transportation Authority Travel Information Center (TIC)Metra Consolidated Control Facilitytransit service coordination
Regional Transportation Authority Travel Information Center (TIC)Metra GPS Center (TIMS)transit service coordination
Regional Transportation Authority Travel Information Center (TIC)Pace Control Center (IBS)transit service coordination
Regional Transportation Authority Travel Information Center (TIC)Pace Regional Paratransit Dispatchtransit service coordination
Regional Transportation Authority Travel Information Center (TIC)Private Bus Dispatchtransit service coordination
RTA/NITA Transit HubChicago Transit Authority Active Transit Station Signstransit traveler information
RTA/NITA Transit HubChicago Transit Authority Bus Info Systemtransit service coordination
RTA/NITA Transit HubChicago Transit Authority BusInfo Signstransit traveler information
RTA/NITA Transit HubChicago Transit Authority Control Centertransit service coordination
RTA/NITA Transit HubGateway Traveler Information System GTIStransit system data
RTA/NITA Transit HubIndependent School District Dispatchtransit service coordination
RTA/NITA Transit HubMetra Consolidated Control Facilitytransit service coordination
RTA/NITA Transit HubMetra GPS Center (TIMS)transit service coordination
RTA/NITA Transit HubMetra Public Address Systemtransit traveler information
RTA/NITA Transit HubMetra Visual Information Display System (VIDS)transit traveler information
RTA/NITA Transit HubMunicipal Transit Operationstransit service coordination
RTA/NITA Transit HubPace BusInfo Signstransit traveler information
RTA/NITA Transit HubPace BusInfo Systemtransit service coordination
RTA/NITA Transit HubPace Control Center (IBS)transit service coordination
RTA/NITA Transit HubPace Regional Paratransit Dispatchtransit service coordination
RTA/NITA Transit HubPrivate Bus Dispatchtransit service coordination
RTA/NITA Transit HubPublic/Non–Profit Paratransit Servicestransit service coordination
RTA/NITA Transit HubRegional Transportation Authority Travel Information Center (TIC)transit service coordination
RTA/NITA Transit HubRTA InfoTrans Signstransit traveler information