US: TCIP - Secure Wireless Internet (ITS)

Description

This solution is used within Canada and the U.S.. It combines standards associated with US: TCIP with those for I–M: Secure Wireless Internet (ITS). The US: TCIP standards include upper–layer standards required to implement transit–related communications. The I–M: Secure Wireless Internet (ITS) standards include lower–layer standards that support secure communications between two entities, either or both of which may be mobile devices, but they must be stationary or only moving within wireless range of a single wireless access point (e.g., a parked car). Security is based on X.509 or IEEE 1609.2 certificates. A non–mobile (if any) endpoint may connect to the service provider using any Internet connection method.

Includes Standards

LevelDocNumFullNameDescription
MgmtIETF RFC 3411An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksThis standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture.
MgmtIETF RFC 3412Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity.
MgmtIETF RFC 3413Simple Network Management Protocol (SNMP) ApplicationsThis standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys.
MgmtIETF RFC 3414User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model.
MgmtIETF RFC 3415View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP.
MgmtIETF RFC 3416Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the message structure and protocol operations used by SNMPv3.
MgmtIETF RFC 3418Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the MIB to configure and manage an SNMP entity.
MgmtIETF RFC 4293Management Information Base for the Internet Protocol (IP)This standard (RFC) defines the MIB that manages an IP entity.
SecurityIETF RFC 5280Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileThis standard (RFC) defines how to use X.509 certificates for secure communications over the Internet.
SecurityIETF RFC 8446The Transport Layer Security (TLS) ProtocolThis standard (RFC) specifies Version 1.3 of the Transport Layer Security (TLS) protocol. The TLS protocol provides communications security over the Internet. The protocol allows client/server applications to communicate in a way that is designed to prevent eavesdropping, tampering, or message forgery.
ITS Application EntityAPTA TCIP–S–001 Vol 2Transit Communications Interface Profiles – TCIP Data and Dialog DefinitionsThis standard defines the data concepts used by the TCIP standard.
FacilitiesW3C XMLExtensible Markup Language (XML) 1.0 (Fifth Edition)This standard defines a generic markup language that can be used to share customizable information by using start and stop tags within the text.
FacilitiesAPTA TCIP–S–001 Vol 2Transit Communications Interface Profiles – TCIP Data and Dialog DefinitionsThis standard defines the data concepts used by the TCIP standard.
TransNetIETF RFC 4291IP Version 6 Addressing ArchitectureThis standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses.
TransNetIETF RFC 4443Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationThis standard (RFC) defines the control messages to manage IPv6.
TransNetIETF RFC 8200Internet Protocol, Version 6This document specifies version 6 of the Internet Protocol (IPv6).
TransNetIETF RFC 9293Transmission Control ProtocolThis document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168.
Access3GPP Network3GPP Cellular Communications NetworkThis proxy standard represents a variety of 3GPP releases and underlying standards and technologies that rely upon cellular base stations for connectivity, including 3G, 4G, and the evolving 5G technologies.

Readiness: Low

Readiness Description

One serious or several significant issues. This category often includes proprietary or partial solutions. The communications solution may fail to provide even a base level of interoperability and security. Consider alternative solutions, or define specific revisions or upgrades that would provide a level of interoperability or security that are needed for the deployment.

Issues

IssueSeverityDescriptionAssociated StandardAssociated Triple
Encoding rules not definedHighThe standards do not unambiguously define which set of encoding rules to use.(None)(All)
Data not fully defined (medium)MediumSome of the data elements for this information flow are not fully defined.(None)Chicago Transit Authority Bus Info System=>transit vehicle operator information=>Chicago Transit Authority Bus Vehicles
Data not fully defined (medium)MediumSome of the data elements for this information flow are not fully defined.(None)Pace Regional Paratransit Dispatch=>transit vehicle operator information=>Pace Paratransit Vehicles
Data not fully defined (medium)MediumSome of the data elements for this information flow are not fully defined.(None)Pace Control Center (IBS)=>transit vehicle operator information=>Pace Transit Bus Vehicles
Data not fully defined (medium)MediumSome of the data elements for this information flow are not fully defined.(None)Metra Consolidated Control Facility=>transit vehicle operator information=>Metra Trains
Data not fully defined (medium)MediumSome of the data elements for this information flow are not fully defined.(None)Chicago Transit Authority Control Center=>transit vehicle operator information=>Chicago Transit Authority Rapid Transit Vehicles
Data not fully defined (medium)MediumSome of the data elements for this information flow are not fully defined.(None)Chicago Transit Authority Control Center=>transit vehicle operator information=>Chicago Transit Authority Bus Vehicles
Out of date (medium)MediumThe standard includes normative references to other standards that have been subject to significant changes that can impact interoperability or security of systems and the industry has not specified if and how these updates should be implemented for deployments of this standard.TCIP – Data(All)
Secure data access not providedMediumThe solution does not define rules on how the application entity authenticates requests to accept or provide data.(None)(All)
Data not defined in standard formatLowThe definition of data concepts should conform to ISO 14817–1 to promote reuse among ITS.TCIP – Data(All)

Supports Interfaces

SourceDestinationFlow
Chicago Transit Authority Bus Info SystemChicago Transit Authority Bus Vehiclesremote vehicle disable
Chicago Transit Authority Bus Info SystemChicago Transit Authority Bus Vehiclestransit vehicle operator information
Chicago Transit Authority Bus VehiclesChicago Transit Authority Bus Info Systemdemand response passenger and use data
Chicago Transit Authority Bus VehiclesChicago Transit Authority Bus Info Systemtransit vehicle conditions
Chicago Transit Authority Bus VehiclesChicago Transit Authority Control Centeralarm notification
Chicago Transit Authority Bus VehiclesChicago Transit Authority Control Centerdemand response passenger and use data
Chicago Transit Authority Bus VehiclesChicago Transit Authority Control Centerfare collection data
Chicago Transit Authority Bus VehiclesChicago Transit Authority Control Centertransit vehicle conditions
Chicago Transit Authority Bus VehiclesChicago Transit Authority Control Centertransit vehicle loading data
Chicago Transit Authority Bus VehiclesChicago Transit Authority Garagestransit vehicle conditions
Chicago Transit Authority Control CenterChicago Transit Authority Bus Vehiclesalarm acknowledge
Chicago Transit Authority Control CenterChicago Transit Authority Bus Vehiclesfare management information
Chicago Transit Authority Control CenterChicago Transit Authority Bus Vehiclesremote vehicle disable
Chicago Transit Authority Control CenterChicago Transit Authority Bus Vehiclestransit vehicle operator information
Chicago Transit Authority Control CenterChicago Transit Authority Rapid Transit Vehiclesalarm acknowledge
Chicago Transit Authority Control CenterChicago Transit Authority Rapid Transit Vehiclesremote vehicle disable
Chicago Transit Authority Control CenterChicago Transit Authority Rapid Transit Vehiclestransit vehicle operator information
Chicago Transit Authority Rapid Transit VehiclesChicago Transit Authority Control Centeralarm notification
Chicago Transit Authority Rapid Transit VehiclesChicago Transit Authority Control Centertransit vehicle conditions
Metra Consolidated Control FacilityMetra Trainsalarm acknowledge
Metra Consolidated Control FacilityMetra Trainsremote vehicle disable
Metra Consolidated Control FacilityMetra Trainstransit vehicle operator information
Metra TrainsMetra Consolidated Control Facilityalarm notification
Metra TrainsMetra Consolidated Control Facilitydemand response passenger and use data
Metra TrainsMetra Consolidated Control Facilitytransit vehicle conditions
Metra TrainsMetra Consolidated Control Facilitytransit vehicle loading data
Metra TrainsMetra GPS Center (TIMS)demand response passenger and use data
Metra TrainsMetra GPS Center (TIMS)transit vehicle loading data
Metra TrainsMetra Maintenance Yardstransit vehicle conditions
Pace Control Center (IBS)Pace Paratransit Vehiclesalarm acknowledge
Pace Control Center (IBS)Pace Paratransit Vehiclesremote vehicle disable
Pace Control Center (IBS)Pace Transit Bus Vehiclesalarm acknowledge
Pace Control Center (IBS)Pace Transit Bus Vehiclesfare management information
Pace Control Center (IBS)Pace Transit Bus Vehiclesremote vehicle disable
Pace Control Center (IBS)Pace Transit Bus Vehiclestransit vehicle operator information
Pace Paratransit VehiclesPace Control Center (IBS)alarm notification
Pace Paratransit VehiclesPace Control Center (IBS)transit vehicle conditions
Pace Paratransit VehiclesPace Regional Paratransit Dispatchalarm notification
Pace Paratransit VehiclesPace Regional Paratransit Dispatchdemand response passenger and use data
Pace Paratransit VehiclesPace Regional Paratransit Dispatchfare collection data
Pace Paratransit VehiclesPace Regional Paratransit Dispatchtransit vehicle conditions
Pace Paratransit VehiclesPace Regional Paratransit Dispatchtransit vehicle loading data
Pace Regional Paratransit DispatchPace Paratransit Vehiclesalarm acknowledge
Pace Regional Paratransit DispatchPace Paratransit Vehiclesfare management information
Pace Regional Paratransit DispatchPace Paratransit Vehiclesremote vehicle disable
Pace Regional Paratransit DispatchPace Paratransit Vehiclestransit vehicle operator information
Pace Regional Paratransit DispatchPace Transit Bus Vehiclesalarm acknowledge
Pace Regional Paratransit DispatchPace Transit Bus Vehiclesremote vehicle disable
Pace Transit Bus VehiclesPace Control Center (IBS)alarm notification
Pace Transit Bus VehiclesPace Control Center (IBS)demand response passenger and use data
Pace Transit Bus VehiclesPace Control Center (IBS)fare collection data
Pace Transit Bus VehiclesPace Control Center (IBS)transit vehicle conditions
Pace Transit Bus VehiclesPace Control Center (IBS)transit vehicle loading data
Pace Transit Bus VehiclesPace Regional Paratransit Dispatchalarm notification
Pace Transit Bus VehiclesPace Regional Paratransit Dispatchtransit vehicle conditions