This solution is used within Canada and the U.S.. It combines standards associated with US: ATIS with those for I–M: Secure Wireless Internet (ITS). The US: ATIS standards include upper–layer standards required to implement traveler information communications. The I–M: Secure Wireless Internet (ITS) standards include lower–layer standards that support secure communications between two entities, either or both of which may be mobile devices, but they must be stationary or only moving within wireless range of a single wireless access point (e.g., a parked car). Security is based on X.509 or IEEE 1609.2 certificates. A non–mobile (if any) endpoint may connect to the service provider using any Internet connection method.
| Level | DocNum | FullName | Description |
|---|
| Mgmt | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Mgmt | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Mgmt | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Mgmt | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Mgmt | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Mgmt | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| Mgmt | IETF RFC 3418 | Management Information Base (MIB) for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the MIB to configure and manage an SNMP entity. |
|---|
| Mgmt | IETF RFC 4293 | Management Information Base for the Internet Protocol (IP) | This standard (RFC) defines the MIB that manages an IP entity. |
|---|
| Security | IETF RFC 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile | This standard (RFC) defines how to use X.509 certificates for secure communications over the Internet. |
|---|
| Security | IETF RFC 8446 | The Transport Layer Security (TLS) Protocol | This standard (RFC) specifies Version 1.3 of the Transport Layer Security (TLS) protocol. The TLS protocol provides communications security over the Internet. The protocol allows client/server applications to communicate in a way that is designed to prevent eavesdropping, tampering, or message forgery. |
|---|
| ITS Application Entity | SAE J2353 | Data Dictionary for Advanced Traveler Information Systems (ATIS) | This document provides a set of core data elements needed by information service providers for Advanced Traveler Information Systems (ATIS). The data dictionary herein provides the foundation for ATIS message sets for all stages of travel (pre–trip and en route), all types of travelers (drivers, passengers), all categories of information, and all platforms for delivery of information (in–vehicle, portable devices, kiosks, etc.). The elements of this document are the basis for the SAE ATIS Message Set Standard J2354 and are entered into the SAE Data Registry for ITS wide coordination. |
|---|
| Facilities | IETF RFC 9110 | HTTP Semantics | The Hypertext Transfer Protocol (HTTP) is a stateless application–level protocol for distributed, collaborative, hypertext information systems. This document describes the overall architecture of HTTP, establishes common terminology, and defines aspects of the protocol that are shared by all versions. In this definition are core protocol elements, extensibility mechanisms, and the "http" and "https" Uniform Resource Identifier (URI) schemes. |
|---|
| Facilities | IETF RFC 9112 | HTTP/1.1 | The Hypertext Transfer Protocol (HTTP) is a stateless application–level protocol for distributed, collaborative, hypertext information systems. This document specifies the HTTP/1.1 message syntax, message parsing, connection management, and related security concerns. |
|---|
| Facilities | W3C XML | Extensible Markup Language (XML) 1.0 (Fifth Edition) | This standard defines a generic markup language that can be used to share customizable information by using start and stop tags within the text. |
|---|
| Facilities | SAE J2354 | Message Sets for Advanced Traveler Information System (ATIS) | This standard defines how to exchange data for Advanced Traveler Information Systems (ATIS). The messages contained herein address all stages of travel (pre–trip and en–route), all types of travelers (drivers, passengers), all categories of information, and all platforms for delivery of information (in–vehicle, portable devices, kiosks, etc.). |
|---|
| TransNet | IETF RFC 4291 | IP Version 6 Addressing Architecture | This standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses. |
|---|
| TransNet | IETF RFC 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification | This standard (RFC) defines the control messages to manage IPv6. |
|---|
| TransNet | IETF RFC 8200 | Internet Protocol, Version 6 | This document specifies version 6 of the Internet Protocol (IPv6). |
|---|
| TransNet | IETF RFC 9293 | Transmission Control Protocol | This document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168. |
|---|
| Access | 3GPP Network | 3GPP Cellular Communications Network | This proxy standard represents a variety of 3GPP releases and underlying standards and technologies that rely upon cellular base stations for connectivity, including 3G, 4G, and the evolving 5G technologies. |
|---|
One serious or several significant issues. This category often includes proprietary or partial solutions. The communications solution may fail to provide even a base level of interoperability and security. Consider alternative solutions, or define specific revisions or upgrades that would provide a level of interoperability or security that are needed for the deployment.
| Issue | Severity | Description | Associated Standard | Associated Triple |
|---|
| Encoding rules not defined | High | The standards do not unambiguously define which set of encoding rules to use. | (None) | (All) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>traveler request=>Private ISPs – Travel Information Services |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | City of Chicago DOT Transportation Website=>trip plan=>User Personal Computing Devices |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Gateway TravelMidwest Website=>trip plan=>User Personal Computing Devices |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Illinois Tollway TMC (TIMS)=>trip plan=>User Personal Computing Devices |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Private ISPs – Travel Information Services=>trip plan=>User Personal Computing Devices |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Regional Transportation Authority Travel Information Center (TIC)=>trip plan=>User Personal Computing Devices |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>trip request=>Pace Regional Ridesharing and Vanpooling |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>trip request=>City of Chicago DOT Transportation Website |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>traveler request=>City of Chicago DOT Transportation Website |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>trip request=>Gateway TravelMidwest Website |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>traveler request=>Gateway TravelMidwest Website |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>trip request=>Illinois Tollway TMC (TIMS) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Pace Regional Ridesharing and Vanpooling=>trip plan=>User Personal Computing Devices |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>trip request=>Private ISPs – Travel Information Services |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>trip request=>Regional Transportation Authority Travel Information Center (TIC) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>traveler request=>Regional Transportation Authority Travel Information Center (TIC) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | User Personal Computing Devices=>traveler request=>Illinois Tollway TMC (TIMS) |
|---|
| Exception handling not defined | Medium | The dialogs do not define how to handle exceptions (e.g., error codes, permission denied, etc). | (None) | (All) |
|---|
| Overlap of standards | Medium | Multiple standards have been developed to address this information and it is unclear which standard should be used to address this specific information flow. | (None) | Pace Regional Ridesharing and Vanpooling=>trip plan=>User Personal Computing Devices |
|---|
| Overlap of standards | Medium | Multiple standards have been developed to address this information and it is unclear which standard should be used to address this specific information flow. | (None) | City of Chicago DOT Transportation Website=>trip plan=>User Personal Computing Devices |
|---|
| Overlap of standards | Medium | Multiple standards have been developed to address this information and it is unclear which standard should be used to address this specific information flow. | (None) | Gateway TravelMidwest Website=>trip plan=>User Personal Computing Devices |
|---|
| Overlap of standards | Medium | Multiple standards have been developed to address this information and it is unclear which standard should be used to address this specific information flow. | (None) | Illinois Tollway TMC (TIMS)=>trip plan=>User Personal Computing Devices |
|---|
| Overlap of standards | Medium | Multiple standards have been developed to address this information and it is unclear which standard should be used to address this specific information flow. | (None) | Private ISPs – Travel Information Services=>trip plan=>User Personal Computing Devices |
|---|
| Overlap of standards | Medium | Multiple standards have been developed to address this information and it is unclear which standard should be used to address this specific information flow. | (None) | Regional Transportation Authority Travel Information Center (TIC)=>trip plan=>User Personal Computing Devices |
|---|
| Performance not fully defined (medium) | Medium | The performance rules are not fully defined for this information flow. | (None) | (All) |
|---|
| Secure data access not provided | Medium | The solution does not define rules on how the application entity authenticates requests to accept or provide data. | (None) | (All) |
|---|
| Data not defined in standard format | Low | The definition of data concepts should conform to ISO 14817–1 to promote reuse among ITS. | SAE J2353 ATIS DD | (All) |
|---|
| Source | Destination | Flow |
|---|
| City of Chicago DOT Transportation Website | User Personal Computing Devices | interactive traveler information |
|---|
| City of Chicago DOT Transportation Website | User Personal Computing Devices | trip plan |
|---|
| Gateway TravelMidwest Website | User Personal Computing Devices | interactive traveler information |
|---|
| Gateway TravelMidwest Website | User Personal Computing Devices | trip plan |
|---|
| Illinois Tollway TMC (TIMS) | User Personal Computing Devices | interactive traveler information |
|---|
| Illinois Tollway TMC (TIMS) | User Personal Computing Devices | trip plan |
|---|
| Pace Regional Ridesharing and Vanpooling | User Personal Computing Devices | trip plan |
|---|
| Private ISPs – Travel Information Services | User Personal Computing Devices | interactive traveler information |
|---|
| Private ISPs – Travel Information Services | User Personal Computing Devices | trip plan |
|---|
| Regional Transportation Authority Travel Information Center (TIC) | User Personal Computing Devices | interactive traveler information |
|---|
| Regional Transportation Authority Travel Information Center (TIC) | User Personal Computing Devices | travel services information |
|---|
| Regional Transportation Authority Travel Information Center (TIC) | User Personal Computing Devices | trip plan |
|---|
| User Personal Computing Devices | City of Chicago DOT Transportation Website | traveler request |
|---|
| User Personal Computing Devices | City of Chicago DOT Transportation Website | trip request |
|---|
| User Personal Computing Devices | Gateway TravelMidwest Website | traveler request |
|---|
| User Personal Computing Devices | Gateway TravelMidwest Website | trip request |
|---|
| User Personal Computing Devices | Illinois Tollway TMC (TIMS) | traveler request |
|---|
| User Personal Computing Devices | Illinois Tollway TMC (TIMS) | trip request |
|---|
| User Personal Computing Devices | Pace Regional Ridesharing and Vanpooling | trip request |
|---|
| User Personal Computing Devices | Private ISPs – Travel Information Services | traveler request |
|---|
| User Personal Computing Devices | Private ISPs – Travel Information Services | trip request |
|---|
| User Personal Computing Devices | Regional Transportation Authority Travel Information Center (TIC) | travel services request |
|---|
| User Personal Computing Devices | Regional Transportation Authority Travel Information Center (TIC) | traveler request |
|---|
| User Personal Computing Devices | Regional Transportation Authority Travel Information Center (TIC) | trip request |
|---|