US: NTCIP Environmental Sensors - SNMPv3/TLS

Description

This solution is used within Canada and the U.S.. It combines standards associated with US: NTCIP Environmental Sensors with those for I–F: SNMPv3/TLS. The US: NTCIP Environmental Sensors standards include upper–layer standards required to implement center–to–field weather and environmental sensor communications. The I–F: SNMPv3/TLS standards include lower–layer standards that support secure center–to–field and field–to–field communications using simple network management protocol (SNMPv3); implementations are strongly encouraged to use the TLS for SNMP security option for this solution to ensure adequate security.

Includes Standards

LevelDocNumFullNameDescription
MgmtNTCIP 1201NTCIP Global Object (GO) DefinitionsThis standard defines SNMP objects (data elements) used by a wide range of field devices like time and versioning information.
MgmtIETF RFC 3411An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksThis standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture.
MgmtIETF RFC 3412Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity.
MgmtIETF RFC 3413Simple Network Management Protocol (SNMP) ApplicationsThis standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys.
MgmtIETF RFC 3414User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model.
MgmtIETF RFC 3415View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP.
MgmtIETF RFC 3416Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the message structure and protocol operations used by SNMPv3.
MgmtIETF RFC 3418Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the MIB to configure and manage an SNMP entity.
MgmtIETF RFC 4293Management Information Base for the Internet Protocol (IP)This standard (RFC) defines the MIB that manages an IP entity.
SecurityIETF RFC 6353Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)This standard (RFC) defines how to use the TLS authentication service to provide authentication within the access control mechanism of SNMP.
SecurityIETF RFC 9456Updates to the TLS Transport Model for SNMP 
ITS Application EntityNTCIP 1204NTCIP Environmental Sensor Station Interface StandardThis standard defines SNMP objects (data elements) for monitoring and controlling environmental sensor stations (especially road weather stations).
FacilitiesNTCIP 1204NTCIP Environmental Sensor Station Interface StandardThis standard defines SNMP objects (data elements) for monitoring and controlling environmental sensor stations (especially road weather stations).
FacilitiesIETF RFC 3411An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksThis standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture.
FacilitiesIETF RFC 3412Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity.
FacilitiesIETF RFC 3413Simple Network Management Protocol (SNMP) ApplicationsThis standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys.
FacilitiesIETF RFC 3414User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model.
FacilitiesIETF RFC 3415View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP.
FacilitiesIETF RFC 3416Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)This standard (RFC) defines the message structure and protocol operations used by SNMPv3.
TransNetIETF RFC 4291IP Version 6 Addressing ArchitectureThis standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses.
TransNetIETF RFC 4443Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationThis standard (RFC) defines the control messages to manage IPv6.
TransNetIETF RFC 8200Internet Protocol, Version 6This document specifies version 6 of the Internet Protocol (IPv6).
TransNetIETF RFC 9293Transmission Control ProtocolThis document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168.
AccessNTCIP 2104NTCIP SP–EthernetThis standard defines the Access Layer for center–to–field communications where the local connection is some variant of Ethernet.

Readiness: High–Moderate

Readiness Description

One significant or possibly a couple minor issues. For existing deployments, the chosen solution likely has identified security or management issues not addressed by the communications solution. Deployers should consider additional security measures, such as communications link and physical security as part of these solutions. They should also review the management issues to see if they are relevant to their deployment and would require mitigation. For new deployments, the deployment efforts should consider a path to addressing these issues as a part of their design activities. The solution does not by itself provide a fully secure implementation without additional work.

Issues

IssueSeverityDescriptionAssociated StandardAssociated Triple
Out of date (medium)MediumThe standard includes normative references to other standards that have been subject to significant changes that can impact interoperability or security of systems and the industry has not specified if and how these updates should be implemented for deployments of this standard.IETF RFC 6353 TLS for SNMP(All)
Accuracy of dataLowThe standard is missing accuracy requirements for some of its data, which may result in anomalous behavior.(None)IDOT Central Bureau of Operations Field Equipment=>environmental sensor data=>Weather Services
Accuracy of dataLowThe standard is missing accuracy requirements for some of its data, which may result in anomalous behavior.(None)IDOT Central Bureau of Operations Field Equipment=>environmental sensor data=>IDOT District 1 ComCenter
Accuracy of dataLowThe standard is missing accuracy requirements for some of its data, which may result in anomalous behavior.(None)Kane County Field Equipment=>environmental sensor data=>Kane County Maintenance Operations
Accuracy of dataLowThe standard is missing accuracy requirements for some of its data, which may result in anomalous behavior.(None)Illinois Tollway TMC Field Equipment=>environmental sensor data=>Weather Services
Accuracy of dataLowThe standard is missing accuracy requirements for some of its data, which may result in anomalous behavior.(None)Illinois Tollway TMC Field Equipment=>environmental sensor data=>Illinois Tollway TMC (TIMS)
Accuracy of dataLowThe standard is missing accuracy requirements for some of its data, which may result in anomalous behavior.(None)IDOT District 1 ComCenter Field Equipment=>environmental sensor data=>IDOT District 1 Traffic Systems Center (TSC)
Accuracy of dataLowThe standard is missing accuracy requirements for some of its data, which may result in anomalous behavior.(None)IDOT District 1 ComCenter Field Equipment=>environmental sensor data=>IDOT District 1 ComCenter
Update data to SNMPv3LowData has been defined for SNMPv1, but needs to be updated to SNMPv3 format.(None)(All)
Use TLS for SNMP OptionLowThe standard allows for multiple security mechanisms. The only defined mechanism that meets the requirements for C–ITS is the one based on TLS.(None)(All)

Supports Interfaces

SourceDestinationFlow
Automated Enforcement CamerasCity of Chicago OEMC Field Equipmentenvironmental sensor coordination
Automated Enforcement CamerasIDOT District 1 ComCenter Field Equipmentenvironmental sensor coordination
Automated Enforcement CamerasIDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor coordination
Automated Enforcement CamerasIllinois Tollway TMC Field Equipmentenvironmental sensor coordination
Automated Enforcement CamerasKane County Field Equipmentenvironmental sensor coordination
Automated Enforcement CamerasKane County Field Equipmentroadway treatment coordination
City of Chicago – Skyway Concession Company LLC Field EquipmentCity of Chicago OEMC Field Equipmentenvironmental sensor coordination
City of Chicago – Skyway Concession Company LLC OperationsCity of Chicago – Skyway Concession Company LLC Field Equipmentenvironmental sensor control
City of Chicago Department of Aviation Field EquipmentCity of Chicago OEMC Field Equipmentenvironmental sensor coordination
City of Chicago DSS Field EquipmentCity of Chicago OEMC Field Equipmentenvironmental sensor coordination
City of Chicago DSS Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor coordination
City of Chicago OEMC Field EquipmentAutomated Enforcement Camerasenvironmental sensor coordination
City of Chicago OEMC Field EquipmentCity of Chicago – Skyway Concession Company LLC Field Equipmentenvironmental sensor coordination
City of Chicago OEMC Field EquipmentCity of Chicago Department of Aviation Field Equipmentenvironmental sensor coordination
City of Chicago OEMC Field EquipmentCity of Chicago DSS Field Equipmentenvironmental sensor coordination
City of Chicago OEMC Field EquipmentCook County Department of Transportation and Highways Field Equipmentenvironmental sensor coordination
City of Chicago OEMC Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentenvironmental sensor coordination
City of Chicago OEMC Field EquipmentIDOT District 1 ComCenter Field Equipmentenvironmental sensor coordination
City of Chicago OEMC Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor coordination
City of Chicago TMCCity of Chicago DSS Field Equipmentenvironmental sensor control
City of Chicago TMCCity of Chicago OEMC Field Equipmentenvironmental sensor control
Cook County Department of Transportation and Highways Field EquipmentCity of Chicago OEMC Field Equipmentenvironmental sensor coordination
Cook County Department of Transportation and Highways Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor coordination
Cook County Department of Transportation and Highways Field EquipmentIllinois Tollway TMC Field Equipmentenvironmental sensor coordination
Cook County Department of Transportation and Highways Field EquipmentLake County Field Equipmentenvironmental sensor coordination
DuPage County Field EquipmentIllinois Tollway TMC Field Equipmentenvironmental sensor coordination
DuPage County Field EquipmentKane County Field Equipmentenvironmental sensor coordination
DuPage County Field EquipmentKane County Field Equipmentroadway treatment coordination
IDOT Central Bureau of Operations Field EquipmentIDOT District 1 ComCenterenvironmental sensor data
IDOT Central Bureau of Operations Field EquipmentWeather Servicesenvironmental sensor data
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentCity of Chicago OEMC Field Equipmentenvironmental sensor coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentIDOT District 1 ComCenter Field Equipmentenvironmental sensor coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentIllinois Tollway TMC Field Equipmentenvironmental sensor coordination
IDOT District 1 Bureau of Traffic – Arterial Operations Field EquipmentLake County Field Equipmentenvironmental sensor coordination
IDOT District 1 ComCenterIDOT Central Bureau of Operations Field Equipmentenvironmental sensor control
IDOT District 1 ComCenterIDOT District 1 ComCenter Field Equipmentenvironmental sensor control
IDOT District 1 ComCenter Field EquipmentAutomated Enforcement Camerasenvironmental sensor coordination
IDOT District 1 ComCenter Field EquipmentCity of Chicago OEMC Field Equipmentenvironmental sensor coordination
IDOT District 1 ComCenter Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentenvironmental sensor coordination
IDOT District 1 ComCenter Field EquipmentIDOT District 1 ComCenterenvironmental sensor data
IDOT District 1 ComCenter Field EquipmentIDOT District 1 Traffic Systems Center (TSC)environmental sensor data
IDOT District 1 ComCenter Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor coordination
IDOT District 1 ComCenter Field EquipmentIllinois Tollway TMC Field Equipmentenvironmental sensor coordination
IDOT District 1 ComCenter Field EquipmentLake County Field Equipmentenvironmental sensor coordination
IDOT District 1 Traffic Systems Center (TSC)IDOT District 1 ComCenter Field Equipmentenvironmental sensor control
IDOT District 1 Traffic Systems Center (TSC)IDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor control
IDOT District 1 Traffic Systems Center Field EquipmentAutomated Enforcement Camerasenvironmental sensor coordination
IDOT District 1 Traffic Systems Center Field EquipmentCity of Chicago DSS Field Equipmentenvironmental sensor coordination
IDOT District 1 Traffic Systems Center Field EquipmentCity of Chicago OEMC Field Equipmentenvironmental sensor coordination
IDOT District 1 Traffic Systems Center Field EquipmentCook County Department of Transportation and Highways Field Equipmentenvironmental sensor coordination
IDOT District 1 Traffic Systems Center Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentenvironmental sensor coordination
IDOT District 1 Traffic Systems Center Field EquipmentIDOT District 1 ComCenter Field Equipmentenvironmental sensor coordination
IDOT District 1 Traffic Systems Center Field EquipmentIDOT Toll Plazas / Gantriesenvironmental sensor coordination
IDOT District 1 Traffic Systems Center Field EquipmentIllinois Tollway TMC Field Equipmentenvironmental sensor coordination
IDOT Toll Plazas / GantriesIDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor coordination
Illinois Tollway TMC (TIMS)Illinois Tollway TMC Field Equipmentenvironmental sensor control
Illinois Tollway TMC Field EquipmentAutomated Enforcement Camerasenvironmental sensor coordination
Illinois Tollway TMC Field EquipmentCook County Department of Transportation and Highways Field Equipmentenvironmental sensor coordination
Illinois Tollway TMC Field EquipmentDuPage County Field Equipmentenvironmental sensor coordination
Illinois Tollway TMC Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentenvironmental sensor coordination
Illinois Tollway TMC Field EquipmentIDOT District 1 ComCenter Field Equipmentenvironmental sensor coordination
Illinois Tollway TMC Field EquipmentIDOT District 1 Traffic Systems Center Field Equipmentenvironmental sensor coordination
Illinois Tollway TMC Field EquipmentIllinois Tollway TMC (TIMS)environmental sensor data
Illinois Tollway TMC Field EquipmentKane County Field Equipmentenvironmental sensor coordination
Illinois Tollway TMC Field EquipmentKane County Field Equipmentroadway treatment coordination
Illinois Tollway TMC Field EquipmentLake County Field Equipmentenvironmental sensor coordination
Illinois Tollway TMC Field EquipmentWeather Servicesenvironmental sensor data
Kane County Field EquipmentAutomated Enforcement Camerasenvironmental sensor coordination
Kane County Field EquipmentAutomated Enforcement Camerasroadway treatment coordination
Kane County Field EquipmentDuPage County Field Equipmentenvironmental sensor coordination
Kane County Field EquipmentDuPage County Field Equipmentroadway treatment coordination
Kane County Field EquipmentIllinois Tollway TMC Field Equipmentenvironmental sensor coordination
Kane County Field EquipmentIllinois Tollway TMC Field Equipmentroadway treatment coordination
Kane County Field EquipmentKane County Maintenance Operationsenvironmental sensor data
Kane County Field EquipmentKane County Maintenance Operationsroadway treatment system status
Kane County Maintenance OperationsKane County Field Equipmentenvironmental sensor control
Kane County Maintenance OperationsKane County Field Equipmentroadway treatment system control
Kane County TMCKane County Field Equipmentenvironmental sensor control
Lake County Field EquipmentCook County Department of Transportation and Highways Field Equipmentenvironmental sensor coordination
Lake County Field EquipmentIDOT District 1 Bureau of Traffic – Arterial Operations Field Equipmentenvironmental sensor coordination
Lake County Field EquipmentIDOT District 1 ComCenter Field Equipmentenvironmental sensor coordination
Lake County Field EquipmentIllinois Tollway TMC Field Equipmentenvironmental sensor coordination
Lake County PASSAGE TMCLake County Field Equipmentenvironmental sensor control
Weather ServicesIDOT Central Bureau of Operations Field Equipmentenvironmental sensor control
Weather ServicesIllinois Tollway TMC Field Equipmentenvironmental sensor control