This solution is used within Canada and the U.S.. It combines standards associated with US: GTFS static with those for I–I: Secure Internet (ITS). The US: GTFS static standards include upper–layer standards required to implement static, public, transit–related communications. The I–I: Secure Internet (ITS) standards include lower–layer standards that support secure communications between ITS equipment using X.509 or IEEE 1609.2 security certificates.
| Level | DocNum | FullName | Description |
|---|
| Mgmt | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Mgmt | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Mgmt | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Mgmt | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Mgmt | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Mgmt | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| Mgmt | IETF RFC 3418 | Management Information Base (MIB) for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the MIB to configure and manage an SNMP entity. |
|---|
| Mgmt | IETF RFC 4293 | Management Information Base for the Internet Protocol (IP) | This standard (RFC) defines the MIB that manages an IP entity. |
|---|
| Security | IETF RFC 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile | This standard (RFC) defines how to use X.509 certificates for secure communications over the Internet. |
|---|
| Security | IETF RFC 8446 | The Transport Layer Security (TLS) Protocol | This standard (RFC) specifies Version 1.3 of the Transport Layer Security (TLS) protocol. The TLS protocol provides communications security over the Internet. The protocol allows client/server applications to communicate in a way that is designed to prevent eavesdropping, tampering, or message forgery. |
|---|
| ITS Application Entity | GTFS | General Transit Feed Specification | This document defines a common (open data) format for exchanging public transportation schedules and associated geographic information. |
|---|
| Facilities | IETF RFC 9110 | HTTP Semantics | The Hypertext Transfer Protocol (HTTP) is a stateless application–level protocol for distributed, collaborative, hypertext information systems. This document describes the overall architecture of HTTP, establishes common terminology, and defines aspects of the protocol that are shared by all versions. In this definition are core protocol elements, extensibility mechanisms, and the "http" and "https" Uniform Resource Identifier (URI) schemes. |
|---|
| Facilities | IETF RFC 9112 | HTTP/1.1 | The Hypertext Transfer Protocol (HTTP) is a stateless application–level protocol for distributed, collaborative, hypertext information systems. This document specifies the HTTP/1.1 message syntax, message parsing, connection management, and related security concerns. |
|---|
| Facilities | ISO 21320–1 | Information technology — Document Container File — Part 1: Core | ISO/IEC 21320–1 specifies the core requirements for 1) document container files, and 2) implementations that produce and/or consume document container files. It normatively references the Zip File Format Specification version 6.3.3 of PKWARE(R) Inc. Document container files are conforming Zip files as specified by that document. |
|---|
| Facilities | IETF RFC 4180 | Common Format and MIME Type for Comma–Separated Values (CSV) Files | This standard (RFC) documents the format used for Comma–Separated Values (CSV) files and registers the associated MIME type "text/csv". |
|---|
| Facilities | IETF RFC 7159 | The JavaScript Object Notation (JSON) Data Interchange Format | The JavaScript Object Notation (JSON), a lightweight, text–based, language–independent data interchange format. It was derived from the ECMAScript Programming Language Standard. JSON defines a small set of formatting rules for the portable representation of structured data. This document removes inconsistencies with other specifications of JSON, repairs specification errors, and offers experience–based interoperability guidance. |
|---|
| TransNet | IETF RFC 4291 | IP Version 6 Addressing Architecture | This standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses. |
|---|
| TransNet | IETF RFC 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification | This standard (RFC) defines the control messages to manage IPv6. |
|---|
| TransNet | IETF RFC 8200 | Internet Protocol, Version 6 | This document specifies version 6 of the Internet Protocol (IPv6). |
|---|
| TransNet | IETF RFC 9293 | Transmission Control Protocol | This document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168. |
|---|
| Access | | Internet Subnet Alternatives | A set of alternative standards that includes any Subnet Layer method of connecting to the Internet. |
|---|
Two significant or one significant and several minor issues. For existing deployments, the chosen solution is likely deficient in security or management capabilities and the issues should be reviewed and upgrades developed as needed. For new deployments, the solution may be viable for pilots when applied to the triples it supports; such pilot deployments should consider a path to addressing these issues as a part of their design activities. The solution does not provide sufficient interoperability, management, and security to enable proper, full–scale deployment without additional work.
| Issue | Severity | Description | Associated Standard | Associated Triple |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Regional Transportation Authority Travel Information Center (TIC)=>transit and fare schedules=>City of Chicago DOT Transportation Website |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Chicago Transit Authority Control Center=>transit and fare schedules=>Regional Transportation Authority Travel Information Center (TIC) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Chicago Transit Authority Control Center=>transit and fare schedules=>Chicago Transit Authority Bus Tracker Website |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | RTA/NITA Transit Hub=>transit and fare schedules=>Pace Regional Ridesharing and Vanpooling |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | RTA/NITA Transit Hub=>transit and fare schedules=>Private ISPs – Travel Information Services |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | RTA/NITA Transit Hub=>transit and fare schedules=>Regional Transportation Authority Travel Information Center (TIC) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Metra Passenger Information Display System=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Metra Consolidated Control Facility=>transit and fare schedules=>IDOT District 1 Traffic Systems Center (TSC) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Metra Consolidated Control Facility=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Pace Control Center (IBS)=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Pace Control Center (IBS)=>transit and fare schedules=>Regional Transportation Authority Travel Information Center (TIC) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Chicago Transit Authority Control Center=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Private Bus Dispatch=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Chicago Transit Authority Bus Info System=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Metra GPS Center (TIMS)=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Chicago Transit Authority ATSS System=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Pace Regional Paratransit Dispatch=>transit and fare schedules=>RTA/NITA Transit Hub |
|---|
| Performance not fully defined (medium) | Medium | The performance rules are not fully defined for this information flow. | (None) | (All) |
|---|
| Secure data access not provided | Medium | The solution does not define rules on how the application entity authenticates requests to accept or provide data. | (None) | (All) |
|---|
| Use case not considered in design (medium) | Medium | While the indicated standards nominally address the information flow, the design may not meet practical constraints because this particular use case was not the focus of the design effort. | (None) | AMTRAK Rail=>alternate mode service data=>RTA/NITA Transit Hub |
|---|
| Use case not considered in design (medium) | Medium | While the indicated standards nominally address the information flow, the design may not meet practical constraints because this particular use case was not the focus of the design effort. | (None) | Chicago Airports=>alternate mode service data=>Chicago Transit Authority Control Center |
|---|
| Use case not considered in design (medium) | Medium | While the indicated standards nominally address the information flow, the design may not meet practical constraints because this particular use case was not the focus of the design effort. | (None) | Chicago Airports=>alternate mode service data=>Regional Transportation Authority Travel Information Center (TIC) |
|---|
| Use case not considered in design (medium) | Medium | While the indicated standards nominally address the information flow, the design may not meet practical constraints because this particular use case was not the focus of the design effort. | (None) | Water Taxi Service=>alternate mode service data=>Metra Consolidated Control Facility |
|---|
| Use case not considered in design (medium) | Medium | While the indicated standards nominally address the information flow, the design may not meet practical constraints because this particular use case was not the focus of the design effort. | (None) | Neighboring Airports=>alternate mode service data=>Regional Transportation Authority Travel Information Center (TIC) |
|---|
| Not a standard (minor) | Low | The document is publicly available and widely used but it is not currently a formal standard. | General Transit Feed Specification | (All) |
|---|
| Source | Destination | Flow |
|---|
| AMTRAK Rail | RTA/NITA Transit Hub | alternate mode service data |
|---|
| Chicago Airports | Chicago Transit Authority Control Center | alternate mode service data |
|---|
| Chicago Airports | Regional Transportation Authority Travel Information Center (TIC) | alternate mode service data |
|---|
| Chicago Transit Authority ATSS System | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Chicago Transit Authority Bus Info System | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Chicago Transit Authority Bus Info System | RTA/NITA Transit Hub | transit fare coordination |
|---|
| Chicago Transit Authority Bus Info System | RTA/NITA Transit Hub | transit fare information |
|---|
| Chicago Transit Authority Control Center | Chicago Airports | transit alternate mode information |
|---|
| Chicago Transit Authority Control Center | Chicago Transit Authority Bus Tracker Website | transit and fare schedules |
|---|
| Chicago Transit Authority Control Center | Chicago Transit Authority Bus Tracker Website | transit fare information |
|---|
| Chicago Transit Authority Control Center | Regional Transportation Authority Travel Information Center (TIC) | transit and fare schedules |
|---|
| Chicago Transit Authority Control Center | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Metra Consolidated Control Facility | IDOT District 1 Traffic Systems Center (TSC) | transit and fare schedules |
|---|
| Metra Consolidated Control Facility | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Metra Consolidated Control Facility | Water Taxi Service | transit alternate mode information |
|---|
| Metra GPS Center (TIMS) | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Metra Passenger Information Display System | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Neighboring Airports | Regional Transportation Authority Travel Information Center (TIC) | alternate mode service data |
|---|
| Other Regional Paratransit Dispatch | Pace Control Center (IBS) | transit fare coordination |
|---|
| Other Regional Paratransit Dispatch | Pace Regional Paratransit Dispatch | transit fare coordination |
|---|
| Pace BusInfo System | Pace WebWatch Internet Site | transit fare information |
|---|
| Pace Control Center (IBS) | Other Regional Paratransit Dispatch | transit fare coordination |
|---|
| Pace Control Center (IBS) | Regional Transportation Authority Travel Information Center (TIC) | transit and fare schedules |
|---|
| Pace Control Center (IBS) | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Pace Regional Paratransit Dispatch | Other Regional Paratransit Dispatch | transit fare coordination |
|---|
| Pace Regional Paratransit Dispatch | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Private Bus Dispatch | RTA/NITA Transit Hub | transit and fare schedules |
|---|
| Regional Transportation Authority Travel Information Center (TIC) | City of Chicago DOT Transportation Website | transit and fare schedules |
|---|
| RTA/NITA Transit Hub | AMTRAK Rail | transit alternate mode information |
|---|
| RTA/NITA Transit Hub | Chicago Transit Authority Bus Info System | transit fare coordination |
|---|
| RTA/NITA Transit Hub | Pace Regional Ridesharing and Vanpooling | transit and fare schedules |
|---|
| RTA/NITA Transit Hub | Private ISPs – Travel Information Services | transit and fare schedules |
|---|
| RTA/NITA Transit Hub | Regional Transportation Authority Travel Information Center (TIC) | transit and fare schedules |
|---|
| Water Taxi Service | Metra Consolidated Control Facility | alternate mode service data |
|---|