This solution is used within Canada and the U.S.. It combines standards associated with US: NTCIP Transportation Sensors with those for I–F: SNMPv3/TLS. The US: NTCIP Transportation Sensors standards include upper–layer standards required to implement center–to–field transportation sensors (e.g., vehicle detectors) communications (e.g., real–time). The I–F: SNMPv3/TLS standards include lower–layer standards that support secure center–to–field and field–to–field communications using simple network management protocol (SNMPv3); implementations are strongly encouraged to use the TLS for SNMP security option for this solution to ensure adequate security.
| Level | DocNum | FullName | Description |
|---|
| Mgmt | NTCIP 1201 | NTCIP Global Object (GO) Definitions | This standard defines SNMP objects (data elements) used by a wide range of field devices like time and versioning information. |
|---|
| Mgmt | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Mgmt | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Mgmt | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Mgmt | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Mgmt | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Mgmt | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| Mgmt | IETF RFC 3418 | Management Information Base (MIB) for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the MIB to configure and manage an SNMP entity. |
|---|
| Mgmt | IETF RFC 4293 | Management Information Base for the Internet Protocol (IP) | This standard (RFC) defines the MIB that manages an IP entity. |
|---|
| Security | IETF RFC 6353 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines how to use the TLS authentication service to provide authentication within the access control mechanism of SNMP. |
|---|
| Security | IETF RFC 9456 | Updates to the TLS Transport Model for SNMP | |
|---|
| ITS Application Entity | NTCIP 1209 | NTCIP Object Definitions for Transportation Sensor Systems (TSS) | This standard defines SNMP objects (data elements) to monitor and control transportation system sensors that measure real–time vehicular traffic information. |
|---|
| Facilities | NTCIP 1209 | NTCIP Object Definitions for Transportation Sensor Systems (TSS) | This standard defines SNMP objects (data elements) to monitor and control transportation system sensors that measure real–time vehicular traffic information. |
|---|
| Facilities | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Facilities | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Facilities | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Facilities | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Facilities | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Facilities | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| TransNet | IETF RFC 4291 | IP Version 6 Addressing Architecture | This standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses. |
|---|
| TransNet | IETF RFC 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification | This standard (RFC) defines the control messages to manage IPv6. |
|---|
| TransNet | IETF RFC 8200 | Internet Protocol, Version 6 | This document specifies version 6 of the Internet Protocol (IPv6). |
|---|
| TransNet | IETF RFC 9293 | Transmission Control Protocol | This document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168. |
|---|
| Access | NTCIP 2104 | NTCIP SP–Ethernet | This standard defines the Access Layer for center–to–field communications where the local connection is some variant of Ethernet. |
|---|
One significant or possibly a couple minor issues. For existing deployments, the chosen solution likely has identified security or management issues not addressed by the communications solution. Deployers should consider additional security measures, such as communications link and physical security as part of these solutions. They should also review the management issues to see if they are relevant to their deployment and would require mitigation. For new deployments, the deployment efforts should consider a path to addressing these issues as a part of their design activities. The solution does not by itself provide a fully secure implementation without additional work.
| Source | Destination | Flow |
|---|
| Automated Enforcement Cameras | City of Chicago DOT Arterial Performance Monitoring System | traffic detector data |
|---|
| Automated Enforcement Cameras | City of Chicago OEMC Field Equipment | traffic detector coordination |
|---|
| Automated Enforcement Cameras | DuPage County Field Equipment | traffic detector coordination |
|---|
| Automated Enforcement Cameras | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| Automated Enforcement Cameras | IDOT District 1 ComCenter Field Equipment | traffic detector coordination |
|---|
| Automated Enforcement Cameras | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector coordination |
|---|
| Automated Enforcement Cameras | Illinois Tollway TMC Field Equipment | traffic detector coordination |
|---|
| Automated Enforcement Cameras | Kane County Field Equipment | traffic detector coordination |
|---|
| City of Chicago – Skyway Concession Company LLC Field Equipment | City of Chicago – Skyway Concession Company LLC Operations | traffic detector data |
|---|
| City of Chicago – Skyway Concession Company LLC Field Equipment | City of Chicago – Skyway Concession Company LLC Operations | traffic situation data |
|---|
| City of Chicago – Skyway Concession Company LLC Field Equipment | City of Chicago OEMC Field Equipment | traffic detector coordination |
|---|
| City of Chicago – Skyway Concession Company LLC Operations | City of Chicago – Skyway Concession Company LLC Field Equipment | traffic detector control |
|---|
| City of Chicago Department of Aviation Field Equipment | City of Chicago OEMC Field Equipment | traffic detector coordination |
|---|
| City of Chicago Department of Aviation Field Equipment | OHare Airport Operations Center | traffic detector data |
|---|
| City of Chicago Department of Aviation Field Equipment | OHare Airport Operations Center | traffic situation data |
|---|
| City of Chicago DOT Arterial Performance Monitoring System | Automated Enforcement Cameras | traffic detector control |
|---|
| City of Chicago DSS Field Equipment | City of Chicago OEMC Field Equipment | traffic detector coordination |
|---|
| City of Chicago DSS Field Equipment | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector coordination |
|---|
| City of Chicago OEMC Field Equipment | Automated Enforcement Cameras | traffic detector coordination |
|---|
| City of Chicago OEMC Field Equipment | City of Chicago – Skyway Concession Company LLC Field Equipment | traffic detector coordination |
|---|
| City of Chicago OEMC Field Equipment | City of Chicago Department of Aviation Field Equipment | traffic detector coordination |
|---|
| City of Chicago OEMC Field Equipment | City of Chicago DSS Field Equipment | traffic detector coordination |
|---|
| City of Chicago OEMC Field Equipment | City of Chicago TMC | traffic detector data |
|---|
| City of Chicago OEMC Field Equipment | Cook County Department of Transportation and Highways Field Equipment | traffic detector coordination |
|---|
| City of Chicago OEMC Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| City of Chicago OEMC Field Equipment | IDOT District 1 ComCenter Field Equipment | traffic detector coordination |
|---|
| City of Chicago OEMC Field Equipment | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector coordination |
|---|
| City of Chicago TMC | City of Chicago OEMC Field Equipment | traffic detector control |
|---|
| Cook County Department of Transportation and Highways Field Equipment | City of Chicago OEMC Field Equipment | traffic detector coordination |
|---|
| Cook County Department of Transportation and Highways Field Equipment | Cook County TMC | traffic detector data |
|---|
| Cook County Department of Transportation and Highways Field Equipment | Cook County TMC | traffic situation data |
|---|
| Cook County Department of Transportation and Highways Field Equipment | DuPage County Field Equipment | traffic detector coordination |
|---|
| Cook County Department of Transportation and Highways Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| Cook County Department of Transportation and Highways Field Equipment | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector coordination |
|---|
| Cook County Department of Transportation and Highways Field Equipment | Illinois Tollway TMC Field Equipment | traffic detector coordination |
|---|
| Cook County Department of Transportation and Highways Field Equipment | Lake County Field Equipment | traffic detector coordination |
|---|
| Cook County TMC | Cook County Department of Transportation and Highways Field Equipment | traffic detector control |
|---|
| DuPage County Centralized Signal Management System | DuPage County Field Equipment | traffic detector control |
|---|
| DuPage County Field Equipment | Automated Enforcement Cameras | traffic detector coordination |
|---|
| DuPage County Field Equipment | Cook County Department of Transportation and Highways Field Equipment | traffic detector coordination |
|---|
| DuPage County Field Equipment | DuPage County Centralized Signal Management System | traffic detector data |
|---|
| DuPage County Field Equipment | DuPage County TMC | traffic detector data |
|---|
| DuPage County Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| DuPage County Field Equipment | Illinois Tollway TMC Field Equipment | traffic detector coordination |
|---|
| DuPage County Field Equipment | Kane County Field Equipment | traffic detector coordination |
|---|
| DuPage County Field Equipment | Municipal/Township Field Equipment | traffic detector coordination |
|---|
| DuPage County Field Equipment | Will County Field Equipment | traffic detector coordination |
|---|
| DuPage County TMC | DuPage County Field Equipment | traffic detector control |
|---|
| Grundy County Field Equipment | Grundy County TMC | traffic detector data |
|---|
| Grundy County TMC | Grundy County Field Equipment | traffic detector control |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | Automated Enforcement Cameras | traffic detector coordination |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | City of Chicago OEMC Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | DuPage County Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Signal Operations | traffic detector data |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | IDOT District 1 ComCenter | traffic detector data |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | IDOT District 1 ComCenter Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | IDOT District 1 Traffic Systems Center (TSC) | traffic detector data |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | Illinois Tollway TMC Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | Lake County Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | Municipal/Township Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Signal Operations | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector control |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Signal Operations | IDOT District 1 ComCenter Field Equipment | traffic detector control |
|---|
| IDOT District 1 Bureau of Traffic – Arterial Signal Operations | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector control |
|---|
| IDOT District 1 ComCenter | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector control |
|---|
| IDOT District 1 ComCenter | IDOT District 1 ComCenter Field Equipment | traffic detector control |
|---|
| IDOT District 1 ComCenter | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector control |
|---|
| IDOT District 1 ComCenter Field Equipment | Automated Enforcement Cameras | traffic detector coordination |
|---|
| IDOT District 1 ComCenter Field Equipment | City of Chicago OEMC Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 ComCenter Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 ComCenter Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Signal Operations | traffic detector data |
|---|
| IDOT District 1 ComCenter Field Equipment | IDOT District 1 ComCenter | traffic detector data |
|---|
| IDOT District 1 ComCenter Field Equipment | IDOT District 1 Traffic Systems Center (TSC) | traffic detector data |
|---|
| IDOT District 1 ComCenter Field Equipment | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 ComCenter Field Equipment | Illinois Tollway TMC Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 ComCenter Field Equipment | Lake County Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Traffic Systems Center (TSC) | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector control |
|---|
| IDOT District 1 Traffic Systems Center (TSC) | IDOT District 1 ComCenter Field Equipment | traffic detector control |
|---|
| IDOT District 1 Traffic Systems Center (TSC) | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector control |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | Automated Enforcement Cameras | traffic detector coordination |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | City of Chicago DSS Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | City of Chicago OEMC Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | Cook County Department of Transportation and Highways Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Signal Operations | traffic detector data |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | IDOT District 1 ComCenter | traffic detector data |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | IDOT District 1 ComCenter Field Equipment | traffic detector coordination |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | IDOT District 1 Traffic Systems Center (TSC) | traffic detector data |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | IDOT Toll Plazas / Gantries | traffic detector coordination |
|---|
| IDOT District 1 Traffic Systems Center Field Equipment | Illinois Tollway TMC Field Equipment | traffic detector coordination |
|---|
| IDOT Toll Plazas / Gantries | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector coordination |
|---|
| Illinois Tollway I–Pass Toll Plazas | Illinois Tollway TMC (TIMS) | traffic detector data |
|---|
| Illinois Tollway I–Pass Toll Plazas | Illinois Tollway TMC (TIMS) | traffic situation data |
|---|
| Illinois Tollway TMC (TIMS) | Illinois Tollway I–Pass Toll Plazas | traffic detector control |
|---|
| Illinois Tollway TMC (TIMS) | Illinois Tollway TMC Field Equipment | traffic detector control |
|---|
| Illinois Tollway TMC Field Equipment | Automated Enforcement Cameras | traffic detector coordination |
|---|
| Illinois Tollway TMC Field Equipment | Cook County Department of Transportation and Highways Field Equipment | traffic detector coordination |
|---|
| Illinois Tollway TMC Field Equipment | DuPage County Field Equipment | traffic detector coordination |
|---|
| Illinois Tollway TMC Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| Illinois Tollway TMC Field Equipment | IDOT District 1 ComCenter Field Equipment | traffic detector coordination |
|---|
| Illinois Tollway TMC Field Equipment | IDOT District 1 Traffic Systems Center Field Equipment | traffic detector coordination |
|---|
| Illinois Tollway TMC Field Equipment | Illinois Tollway TMC (TIMS) | traffic detector data |
|---|
| Illinois Tollway TMC Field Equipment | Kane County Field Equipment | traffic detector coordination |
|---|
| Illinois Tollway TMC Field Equipment | Lake County Field Equipment | traffic detector coordination |
|---|
| Kane County Field Equipment | Automated Enforcement Cameras | traffic detector coordination |
|---|
| Kane County Field Equipment | DuPage County Field Equipment | traffic detector coordination |
|---|
| Kane County Field Equipment | Illinois Tollway TMC Field Equipment | traffic detector coordination |
|---|
| Kane County Field Equipment | Kane County TMC | traffic detector data |
|---|
| Kane County Field Equipment | Kane County TMC | traffic situation data |
|---|
| Kane County TMC | Kane County Field Equipment | traffic detector control |
|---|
| Kendall County Field Equipment | Kendall County TMC | traffic detector data |
|---|
| Kendall County TMC | Kendall County Field Equipment | traffic detector control |
|---|
| Lake County Field Equipment | Cook County Department of Transportation and Highways Field Equipment | traffic detector coordination |
|---|
| Lake County Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| Lake County Field Equipment | IDOT District 1 ComCenter Field Equipment | traffic detector coordination |
|---|
| Lake County Field Equipment | Illinois Tollway TMC Field Equipment | traffic detector coordination |
|---|
| Lake County Field Equipment | Lake County PASSAGE TMC | traffic detector data |
|---|
| Lake County PASSAGE TMC | Lake County Field Equipment | traffic detector control |
|---|
| McHenry County Field Equipment | McHenry County TMC | traffic detector data |
|---|
| McHenry County TMC | McHenry County Field Equipment | traffic detector control |
|---|
| Municipal/Township Field Equipment | DuPage County Field Equipment | traffic detector coordination |
|---|
| Municipal/Township Field Equipment | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | traffic detector coordination |
|---|
| OHare Airport Operations Center | City of Chicago Department of Aviation Field Equipment | traffic detector control |
|---|
| Will County Field Equipment | DuPage County Field Equipment | traffic detector coordination |
|---|
| Will County Field Equipment | Will County TMC | traffic detector data |
|---|
| Will County TMC | Will County Field Equipment | traffic detector control |
|---|