This solution is used within Canada and the U.S.. It combines standards associated with US: SAE Signal Preemption with those for V–X: WAVE TCP. The US: SAE Signal Preemption standards include upper–layer standards required to implement signal preemption and priority information flows. The V–X: WAVE TCP standards include lower–layer standards that support connection–oriented vehicle–to–any communications within ~300m using the Transmission Control Protocol (TCP) over Internet Protocol version 6 (IPv6) over IEEE WAVE in the 5.9GHz spectrum.
| Level | DocNum | FullName | Description |
|---|
| Mgmt | Addressed Elsewhere | Addressed Elsewhere in Stack | The services related to this portion of the stack are defined in the other standards listed for this solution. |
|---|
| Security | IEEE 1609.2 | IEEE Standard for Wireless Access in Vehicular Environments – Security Services for Applications and Management Messages | This standard defines secure message formats and processing for use by Wireless Access in Vehicular Environments (WAVE) devices, including methods to secure WAVE management messages and methods to secure application messages. It also describes administrative functions necessary to support the core security functions. |
|---|
| Security | IEEE 1609.2a | IEEE 1609.2a–2017 – IEEE Standard for Wireless Access in Vehicular Environments––Security Services for Applications and Management Messages – Amendment 1 | This standard defines secure message formats and processing for use by Wireless Access in Vehicular Environments (WAVE) devices, including methods to secure WAVE management messages and methods to secure application messages. It also describes administrative functions necessary to support the core security functions. |
|---|
| Security | IEEE 1609.2b | IEEE Standard for Wireless Access in Vehicular Environments––Security Services for Applications and Management Messages – Amendment 2––PDU Functional Types and Encryption Key Management | This standard defines secure message formats and processing for use by Wireless Access in Vehicular Environments (WAVE) devices, including methods to secure WAVE management messages and methods to secure application messages. It also describes administrative functions necessary to support the core security functions. |
|---|
| ITS Application Entity | ISO 19091 | Intelligent transport systems –– Cooperative ITS –– Using V2I and I2V communications for applications related to signalized intersections | This technical specification defines messages and related data structures and data elements for the following exchanges between roadside equipment and vehicles: 1) Definition of the SPaT (signal phase and timing) message transmitted from a traffic controller that describes the state of the signals, signal timing as necessary to support the applications identified herein; 2) definition of the MAP message (which include the definition of motorized lane, vehicles, busses, trams, bicycle, pedestrian crosswalks, etc.); and 3) definition of the messages (SRM, SSM) to be exchanged between an intersection traffic controller and approaching vehicles to support priority treatment as might be expected for emergency response , freight transport, and public transport vehicles to improve safety. |
|---|
| ITS Application Entity | SAE J2735 | V2X Communications Message Set Dictionar | This standard defines the data and messages for use in DSRC (i.e., V2V, V2I, and V2D) applications. The SAE J2945 series defines additional requirements on how to use these messages. |
|---|
| ITS Application Entity | SAE J2945/B | Recommended Practices for Signalized Intersection Applications | This document provides guidance on usage of SAE J2735 and other related information for signalized intersection applications. The document focuses on how to use SPaT and MAP messages to support signalized–intersection applications. In general, implementation guidance is necessary to achieve interoperability by addressing the requirements for the options for both over the air dialogs and message contents, and to support larger intersection maps This document also addresses using Signal Request & Signal Status messages corresponding to vehicle functionality and approaches to traffic signal priority/pre–emption (TSP), including three different methods for implementing TSP over the air. The project is complementary to the connected intersections project being performed by ITE. |
|---|
| ITS Application Entity | CTI 4501 | Connected Intersections Implementation Guide | This Connected Intersection (CI) Implementation Guide defines the key capabilities and interfaces a connected signalized intersection must support to ensure interoperability with production vehicles for state and local IOOs. A connected intersection is defined as an infrastructure system that broadcasts SPaT, MAP, and position correction data to vehicles. |
|---|
| Facilities | SAE J2735 | V2X Communications Message Set Dictionar | This standard defines the data and messages for use in DSRC (i.e., V2V, V2I, and V2D) applications. The SAE J2945 series defines additional requirements on how to use these messages. |
|---|
| Facilities | SAE J2945 | Dedicated Short Range Communication (DSRC) Systems Engineering Process Guidance for J2945/x Documents and Common Design Concepts | This standard defines cross–cutting material which applies to the J2945/x series including generic DSRC interface requirements and guidance on Systems Engineering (SE) content. |
|---|
| TransNet | IETF RFC 4291 | IP Version 6 Addressing Architecture | This standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses. |
|---|
| TransNet | IETF RFC 4861 | Neighbor Discovery for IP version 6 (IPv6) | This standard (RFC) specifies the Neighbor Discovery protocol for IP Version 6. IPv6 nodes on the same link use Neighbor Discovery to discover each other's presence, to determine each other's link–layer addresses, to find routers, and to maintain reachability information about the paths to active neighbors. |
|---|
| TransNet | IETF RFC 4862 | IPv6 Stateless Address Autoconfiguration | This standard (RFC) specifies the steps a host takes in deciding how to autoconfigure its interfaces in IP version 6. The autoconfiguration process includes generating a link–local address, generating global addresses via stateless address autoconfiguration, and the Duplicate Address Detection procedure to verify the uniqueness of the addresses on a link. |
|---|
| TransNet | IETF RFC 8200 | Internet Protocol, Version 6 | This document specifies version 6 of the Internet Protocol (IPv6). |
|---|
| TransNet | IETF RFC 9293 | Transmission Control Protocol | This document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168. |
|---|
| TransNet | IEEE 1609.3 | IEEE Standard for Wireless Access in Vehicular Environments (WAVE) – Networking Services | This standard defines the network and transport layer options for the WAVE environment. The standard defines three options: a bandwidth efficient single–hop solution known as WSMP, UDP/IP, and TCP/IP. It has been harmonized with ISO FNTP and FSAP – a common message format specified in ISO 16460. |
|---|
| Access | IEEE 1609.4 | IEEE Draft Standard for Wireless Access in Vehicular Environments – Multi–Channel Operation | This standard primarily defines the data link layer of the WAVE communications stack. |
|---|
| Access | IEEE 802.11 | IEEE Draft Standard for Information technology––Telecommunications and information exchange between systems Local and metropolitan area networks––Specific requirements Part 11: Wireless LAN Medium Access Control (MAC) and Physical Layer (PHY) Specificatio | This standard defines the physical and data link layers for wireless Ethernet, including WiFi and DSRC. |
|---|
| Access | ISO/IEC 8802–2 | IEEE Standard for Information technology –– Telecommunications and information exchange between systems––Local and metropolitan area networks –– Specific requirements –– Part 2: Logical Link Control | ISO/IEC 8802–2 describes the logical link control (LLC) sublayer, which constitutes the top sublayer in the data link layer of the ISO 8802 Local Area Network Protocol (also known as IEEE 802.2). |
|---|
Many serious issues. This category includes solutions that have not been standardized, or do not have a basic level of interoperability or security. Consider selecting a different communications solution or if this is not possible (eg. a pilot of a new application that has not been standardized), take additional measures to provide an acceptable level of security or interoperability.
| Source | Destination | Flow |
|---|
| Chicago Transit Authority Bus Vehicles | City of Chicago OEMC Field Equipment | local signal priority request |
|---|
| Chicago Transit Authority Bus Vehicles | Cook County Department of Transportation and Highways Field Equipment | local signal priority request |
|---|
| Chicago Transit Authority Bus Vehicles | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | local signal priority request |
|---|
| Municipal Public Safety Vehicles | City of Chicago OEMC Field Equipment | local signal preemption request |
|---|
| Municipal Public Safety Vehicles | Cook County Department of Transportation and Highways Field Equipment | local signal preemption request |
|---|
| Municipal Public Safety Vehicles | DuPage County Field Equipment | local signal preemption request |
|---|
| Municipal Public Safety Vehicles | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | local signal preemption request |
|---|
| Municipal Public Safety Vehicles | Kane County Field Equipment | local signal preemption request |
|---|
| Municipal Public Safety Vehicles | Lake County Field Equipment | local signal preemption request |
|---|
| Municipal Public Safety Vehicles | Municipal/Township Field Equipment | local signal preemption request |
|---|
| Pace Transit Bus Vehicles | City of Chicago OEMC Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | Cook County Department of Transportation and Highways Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | DuPage County Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | Grundy County Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | IDOT District 1 Bureau of Traffic – Arterial Operations Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | Kane County Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | Kendall County Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | Lake County Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | McHenry County Field Equipment | local signal priority request |
|---|
| Pace Transit Bus Vehicles | Will County Field Equipment | local signal priority request |
|---|